Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all, I am using SLES 10 SP3(x86_64). I was trying to install gtk/wxwidget through yast. After that i rebooted my system, now system is failing to load in GUI ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    12

    Failing to load the gnome session, GTK warning: cannot open display


    Hi all,
    I am using SLES 10 SP3(x86_64).
    I was trying to install gtk/wxwidget through yast.
    After that i rebooted my system, now system is failing to load in GUI mode.
    If i can give the log of last few lines are as follows

    "Starting CRON daemon done
    Master Resource Control: runlevel 5 has been reached
    skipped services in runlevel 5:

    Welcome to SUSE Linux ...... "
    Then it asks for login, only shell is available for me. How to login to gui mode..
    Plsssssssss help.
    I tried using the command gnome-session it gives error
    (gnome-session: 4101): Gtk-Warning **: cannot open display:


    Also i tried using init 5, but again it prompts the my servername.

    pls pls help

  2. #2
    Just Joined!
    Join Date
    Jul 2009
    Posts
    7
    First of all of course you can't run gnome session! If the X server isn't started it won't run, simple as that, gnome-session does not launch an X server. That's similar to trying to start a car without gas and it just auto-magically fills the tank up itself!

    What ya need to do is find out where the "gdm" script is located, this script launches gdm (Gnome Display Manager), which is your "login screen."

    Code:
    sudo find /etc -name gdm
    ^ That will output the location of gdm

    Secondly, run that script by typing in the absolute path of the script.

    Here is an example:
    Code:
    adam@adam-nix ~# sudo find /etc -name gdm
    /etc/rc.d/init.d/gdm
    adam@adam-nix ~# /etc/rc.d/init.d/gdm
    Obviously the location will probably be different than mine, I don't use gdm I just created an empty file to demostrate.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •