Find the answer to your Linux question:
Results 1 to 5 of 5
I have Suse 11.1 and am running a customized server on it that will take care of mounting/unmounting media (DVD, USB key, etc) on its own .. How can I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2007
    Posts
    5

    how to turn OFF automount of media in Suse 11.1


    I have Suse 11.1 and am running a customized server on it that will take care of mounting/unmounting media (DVD, USB key, etc) on its own ..

    How can I get Suse to stop mounting the media automatically when I insert a dvd into the drive or plug in a USB key?

    I already got it to stop opening a window showing the contents, now need to get it to stop mounting automatically ..

  2. #2
    Linux Newbie
    Join Date
    Dec 2009
    Posts
    104
    Hi,

    My Gawd, something I think I can actually answer!!! I'm still very new to Linux, and I "believe" this is teh correct answer for you...

    Look in /etc/, you will find a file called fstab. It mounts devices upon boot...
    You will probably find something that looks like this...


    proc /proc proc defaults 0 0
    /dev/sdb1 / ext3 errors=remount-ro 0 1
    /dev/sda1 /media/sda1 ntfs-3g defaults,locale=en_US.UTF-8,force 0 0
    /dev/sdb5 none swap sw 0 0
    #/dev/hdb /media/cdrom0 auto user,auto 0 0



    Note the entry for hdb, change "auto" to "noauto", I believe this will stop automount.

    You should wait a bit to see if someone corrects me on this, but I am pretty sure this is one way...

    Dave

  3. #3
    Just Joined!
    Join Date
    Apr 2007
    Posts
    5
    Quote Originally Posted by Dave-Oregon View Post
    Hi,

    My Gawd, something I think I can actually answer!!! I'm still very new to Linux, and I "believe" this is teh correct answer for you...

    Look in /etc/, you will find a file called fstab. It mounts devices upon boot...
    You will probably find something that looks like this...


    proc /proc proc defaults 0 0
    /dev/sdb1 / ext3 errors=remount-ro 0 1
    /dev/sda1 /media/sda1 ntfs-3g defaults,locale=en_US.UTF-8,force 0 0
    /dev/sdb5 none swap sw 0 0
    #/dev/hdb /media/cdrom0 auto user,auto 0 0



    Note the entry for hdb, change "auto" to "noauto", I believe this will stop automount.

    You should wait a bit to see if someone corrects me on this, but I am pretty sure this is one way...

    Dave
    Thanks for the try .. unfortunately if I turn the 1st "auto" to "noauto", it doesn't mount because the system is being told not to automatically detect the filesystem, which I would like to keep so I don;t have tomount -t every time as root ..

    I am running Gnome for my shell on Suse 11 in case that helps anyone looking at this.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    It's GNOME that handles automounting external media. I don't use GNOME and it's changed, I think, it more recent releases, so I'm not sure exactly where the preference options are, but look for something called Removable Drives and Media in the Preferences menu, or check for a Media tab in the Nautilus preference menu.

    Failing that, using gconf-editor (you may need to install it), go to /apps/nautilus/preferences/media_automount and you should be able to change it.

  6. #5
    Just Joined!
    Join Date
    Apr 2007
    Posts
    5
    Quote Originally Posted by reed9 View Post
    It's GNOME that handles automounting external media. I don't use GNOME and it's changed, I think, it more recent releases, so I'm not sure exactly where the preference options are, but look for something called Removable Drives and Media in the Preferences menu, or check for a Media tab in the Nautilus preference menu.

    Failing that, using gconf-editor (you may need to install it), go to /apps/nautilus/preferences/media_automount and you should be able to change it.
    That was it .. went into the gnome configuration editor, searched on automount and turned it off .. thanks!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •