Find the answer to your Linux question:
Results 1 to 5 of 5
I have provided a friend of mine with an old PC running SuSE Linux. Recently I installed some updates for him and later the phoned me to say that Firefox ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    8

    [SOLVED] Firefox has Stopped Working


    I have provided a friend of mine with an old PC running SuSE Linux. Recently I installed some updates for him and later the phoned me to say that Firefox had stopped working. On trying to launch it he gets a bouncing icon for a while but the application never comes up.

    I gave him instructions on updating Firefox by going to the Computer tab and choosing Install Software. However, this did not make it work. Does anyone have suggestions for fixing this? Is there a preferences file I can remove in order to get back to default settings?

    The Konqueror web browser is okay so there is no problem with Internet access.

    Many thanks

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Execute firefox command in Terminal and post error message here, if any.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Quote Originally Posted by a1kidner View Post
    Is there a preferences file I can remove in order to get back to default settings?
    Yes, you can try renaming the hidden ~/ .mozilla folder then starting Firefox to see if that fixes it. If it doesn't, you can delete the newly created .mozilla folder and change the name back to what it was on the original folder and look for other solutions.
    oz

  4. #4
    Just Joined!
    Join Date
    Jul 2004
    Posts
    8

    Unhappy Error Message

    I renamed the .mozilla folder, typed firefox at the prompt, and got this error:

    'Could not find compatible GRE between version 1.9.0.13 and 1.9.0.13'

  5. #5
    Just Joined!
    Join Date
    Jul 2004
    Posts
    8

    Fixed Firefox as Follows:

    UNINSTALL FIREFOX
    - Application launcher > Computer tab > Install Software
    - Enter your password
    - Type firefox in the Search box and click Search button
    - Click the tick box beside MozillaFirefox until the tick turns in to a red cross. At this point an error message may spring up! Just close the box with the x in the top right corner.
    - Click any other ticked boxes until they have a red x too (probably just one other MozillaFirefox-branding-openSUSE). Again you may need to close an error dialogue box.
    - Click Accept button
    - Restart the computer to make sure the new settings have taken effect

    REINSTALL FIREFOX
    - Application launcher > Computer tab > Install Software
    - Enter your password
    - Type firefox in the Search box and click Search button
    - Click tick box for MozillaFirefox
    - Click tick box for MozillaFirefox-branding-openSUSE
    - Click tick box to remove ticks or marks from any other boxes
    - You should have two green ticks showing
    - Click Accept button
    - A new window should open showing automatic changes to resolve dependencies. You should not need to change any of these options. Look out for mozilla-xulrunner191; three entries in the list each starting with a tick (xulrunner is what is causing the current error message)
    - Click the Continue button
    - When the installation has completed you should be able to go to your desktop icon for Firefox (the correct icon should come back when you click it) and launch the program with a double click. If not you use the search option in the Application Launcher or find the icon in the menu.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •