Find the answer to your Linux question:
Results 1 to 4 of 4
Hallo!I have a dual-boot system having installed openSUSE 11.3 and Windows XP. I tried to create an NTFS partition inside the extended partition that hosts my Linux partitions. When I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2010
    Posts
    3

    Error 15:file not found openSUSE 11.3


    Hallo!I have a dual-boot system having installed openSUSE 11.3 and Windows XP.

    I tried to create an NTFS partition inside the extended partition that hosts my Linux partitions.

    When I rebooted my machine,it could not load the grub bootloader and an error below appears

    error 15:file not found

    I have tried using super grub disk to recover the grub but no luck.I have reverted to the XP bootloader to at least launch my XP

    Using the openSUSE Installation DVD,I have selected the Rescue System.On its terminal,I entered grub and from the command below

    grub >find /boot/grub/menu.lst

    It cannot find the grub file.In fact,there is no file or folder in the boot directory.

    How do I recover my grub bootloader?

    Thanks

  2. #2
    Just Joined!
    Join Date
    Dec 2010
    Posts
    3

    Restoring Grub

    access the grub command line on bootup or using the linux install disk. At the "grub>>" prompt, type "find /boot/grub/stage1". This should return something like (hd0,1). Using the value that is returned from find, make that your root grub directory by typing "root(hd*,*)" where you fill in the blank for the asterisks. Then type "setup (hd*)" inserting a value for the asterisk. This setup parameter will be where the grub is to be installed. For example, use setup (hd0) to install to the MBR of the first hard drive. Hope this helps.

  3. #3
    Just Joined!
    Join Date
    Nov 2010
    Posts
    3
    I had already tried what kizbot77 has suggested (please see my initial post) but it didnt work.

    Maybe,its because I also realized that in the rescue system, the /boot directory is from the live dvd rescue subsystem.How do I access my installed system?

    I have tried using chroot but no syntax works.

    Please assist in accessing my installed system.

  4. #4
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    You need to mount the partitions from the drive first.

    You did not say what you used to make the NTFS partition. If Windows....Windows spits on Linux. So maybe you over wrote one or more of the Linux partitions since Windows only recognizes Windows, since we all know there is only one true operating system.</sarcasm>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •