Find the answer to your Linux question:
Results 1 to 4 of 4
I can't seem to install the hamachi tarball for my openSUSE I've tried it several times now and I keep getting the same issues. Here is what I entered into ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2011
    Posts
    2

    Unhappy Another Tarball install issue


    I can't seem to install the hamachi tarball for my openSUSE
    I've tried it several times now and I keep getting the same issues.
    Here is what I entered into XTerm:
    Code:
    cd /home/remco/src
    tar zxvf hamachi- 0.9.9.9-20-lnx
    ./configure
    Here is the part that goes wrong
    when I type ./configure I get an error that it doesn't recognise the command.
    In the readme file it says that I have to run make install, but that gives me the same error, can somebody help me??
    I'm just a newbie so I wont understand everything, but I just want this working!

  2. #2
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,280
    It looks like this tarball doesn't include a configure file. It's probably a precompiled package. You can check what it actually contains by listing the directory with ls.

    Have you actually got the make command on your system? Check by typing which make. If you get "No make" you'll have to start by installing that. Then you can use make to install hamachi.
    "I'm just a little old lady; don't try to dazzle me with jargon!"
    www.hrussman.entadsl.com

  3. #3
    Linux Guru Lakshmipathi's Avatar
    Join Date
    Sep 2006
    Location
    3rd rock from sun - Often seen near moon
    Posts
    1,769
    Post the complete error message.

    Few things that might help.
    1. Are you sure tar file is not corrupt? check the downloaded tar md5sum from original site
    2.As Hazel said, Do you have build essentials like make/automake/autoconf ? else install them first and then try again. Checkout README/INSTALL file ,on most software's it will have installation steps.
    First they ignore you,Then they laugh at you,Then they fight with you,Then you win. - M.K.Gandhi
    -----
    FOSS India Award winning ext3fs Undelete tool www.giis.co.in. Online Linux Terminal http://www.webminal.org

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2011
    Posts
    2

    Talking Fixed!

    Stupid me!
    thanx hazel, I didn't have the build package
    should've thought about that earlier!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •