Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
when mail is sent from Suse linux system, I get the following error. Diagnostic-Code: X-Postfix; delivery via local: unknown user: "xxxxxxx" please help me in resolving the same...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2011
    Posts
    11

    Problem with postfix


    when mail is sent from Suse linux system, I get the following error.

    Diagnostic-Code: X-Postfix; delivery via local: unknown user:
    "xxxxxxx"

    please help me in resolving the same

  2. #2
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    3,345
    Well, it does say "unknown user" and it tries to deliver locally.

    a) is this user/mailaccount supposed to be local?
    b) if yes, does this mailaccount exist?
    c) if still yes, do all mappings/aliases look ok?
    You must always face the curtain with a bow.

  3. #3
    Just Joined!
    Join Date
    May 2011
    Posts
    11
    Hi,

    a) The mail account is not local it is a valid company mail id(hp.com)
    b)this is a valid maild id and it exists
    c) Please let me know what r the mappings/aliases to be done...I am new to this issue

  4. #4
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    3,345
    Hmm,
    1) Can I see a complete transaction (grep for the mailid) of a failed delivery to that @hp.com address?
    Of course: please obfuscate email addresses before posting here.

    2) email to other remote smtp server works?
    If yes, then a wrongly spelled email address for @hp.com is most likely.
    You must always face the curtain with a bow.

  5. #5
    Just Joined!
    Join Date
    May 2011
    Posts
    11
    The mail is not delivered to other smtp servers also

    I hv pasted the content of /var/mail/root

    Enclosed is the mail delivery report that you requested.

    The mail system

    <xxx.yyyy@hp.com>: delivery via local: unknown user:
    "xxx.yyyy"

    --45D648A47E.1305117624/vm-sles11.hp.com
    Content-Description: Delivery report
    Content-Type: message/delivery-status

    Reporting-MTA: dns; vm-sles11.hp.com
    X-Postfix-Queue-ID: 45D648A47E
    X-Postfix-Sender: rfc822; root@vm-sles11.hp.com
    Arrival-Date: Wed, 11 May 2011 07:40:24 -0500 (CDT)

    Final-Recipient: rfc822; xxx.yyyy@hp.com
    Action: failed
    Status: 5.1.1
    Diagnostic-Code: X-Postfix; delivery via local: unknown user:
    "xxx.yyyy"

    --45D648A47E.1305117624/vm-sles11.hp.com
    Content-Description: Message Headers
    Content-Type: text/rfc822-headers

    Received: by vm-sles11.hp.com (Postfix, from userid 0)
    id 45D648A47E; Wed, 11 May 2011 07:40:24 -0500 (CDT)
    Date: Wed, 11 May 2011 07:40:24 -0500
    To: xxx.yyyy@hp.com
    Subject: may116
    User-Agent: Heirloom mailx 12.2 01/07/07
    MIME-Version: 1.0
    Content-Type: text/plain; charset=us-ascii
    Content-Transfer-Encoding: quoted-printable
    Message-Id: <20110511124024.45D648A47E@vm-sles11.hp.com>
    From: root@vm-sles11.hp.com (root)

    --45D648A47E.1305117624/vm-sles11.hp.com--
    Last edited by ansan; 05-12-2011 at 04:45 AM.

  6. #6
    Just Joined!
    Join Date
    May 2011
    Posts
    11
    Previously i faces another issue

    <xxx.yyyy@hp.com>: delivery via
    smtp.hp.com[15.216.28.48]:25: host smtp.hp.com[15.216.28.48] said: 550
    5.1.8 <root@vm-sles11-64.site>: Sender address rejected: Domain not found
    (in reply to RCPT TO command)

    I made some changes in main.cf

    then i started getting that "unknown user " error as stated above

  7. #7
    Just Joined!
    Join Date
    Dec 2009
    Location
    California
    Posts
    98
    If I had to guess, I'd say that the changes you made are making postfix think that your local computer is responsible for hp.com....

    Whatever change you made, you should revert it.

    Does a DNS lookup work for you?
    $ dig hp.com in mx

  8. #8
    Just Joined!
    Join Date
    May 2011
    Posts
    11
    I have reverted back the changes and now i face the same problem
    <xxx.yyyy@hp.com>: delivery via
    smtp.hp.com[15.216.28.48]:25: host smtp.hp.com[15.216.28.48] said: 550
    5.1.8 <root@vm-sles11-64.site>: Sender address rejected: Domain not found
    (in reply to RCPT TO command)

    The output of the cmd u said dig hp.com in mx is as follows

    vm-sles11-64:~ # dig hp.com in mx



    ; <<>> DiG 9.5.0-P2 <<>> hp.com in mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57919
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;hp.com. IN MX

    ;; ANSWER SECTION:
    hp.com. 1379 IN MX 10 smtp.hp.com.

    ;; ADDITIONAL SECTION:
    smtp.hp.com. 20 IN A 15.201.24.91

    ;; Query time: 5 msec
    ;; SERVER: 16.110.135.52#53(16.110.135.52)
    ;; WHEN: Fri May 13 00:15:10 2011
    ;; MSG SIZE rcvd: 61

  9. #9
    Just Joined!
    Join Date
    Dec 2009
    Location
    California
    Posts
    98
    Yeah, so that is pretty clear. Your server is trying to deliver the mail, but it's being rejected by the hp mail server because "SENDER domain" is being rejected.

    Your IP address probably resolves to something bad or not at all.
    By something bad, I mean something with dhcp or dialup in the name.

  10. #10
    Just Joined!
    Join Date
    May 2011
    Posts
    11
    Can u please say what should be done to resolve the ip address problem as u mentioned above

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •