Find the answer to your Linux question:
Results 1 to 3 of 3
Hello, I'm a Linux newbie, and I have SUSE 11.1 I try to install jdk-6u25-linux-x64.bin by first changing the executable rights, then with the ./"filename" command but I receive the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2011
    Posts
    1

    Trouble installing JDK on Suse 64bit


    Hello, I'm a Linux newbie, and I have SUSE 11.1
    I try to install jdk-6u25-linux-x64.bin by first changing the executable rights, then with the ./"filename" command but I receive the error "./install.sfx.#####: cannot execute binary file."
    I've tried moving the file to the /bin directory, with no luck.
    If I use the RPM version, it gives me the same error.
    Any and all help is appreciated. Thank you in advance.

  2. #2
    Linux User
    Join Date
    Sep 2008
    Location
    UK
    Posts
    358
    If you are using the oracle version, you need to be root to run it.
    Open a terminal and navigate to the download directory for jre.
    Now type su and the root passwrod, when prompted.
    now type:
    Code:
    sh ./jre-rest-of-name.bin
    This will create a .rpm file.
    To install it type:
    rpm -uvH jre-rest-of-name.rpm

    The easy way to do it is use yast>software.
    Type jre- in the seach window and it should find jre in the opensuse software list.
    If this doesn't find it, try oracle or java runtime as filters.
    If its still not found, select the repository button and then edit and add. (I think, not at a suse machine)
    Choose community repo radio button and select the Packman repo.
    Once added, you should now be able to find and fiinstall jjre.

  3. #3
    Linux Newbie
    Join Date
    Jun 2004
    Location
    Halesowen, West Midlands, UK
    Posts
    107
    Either use yast or "zypper se java" where you'll see all that's available and you can install what you want using "zypper in java-xxxx".

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •