Hello,

I got OpenSUSE 11.4 joined in my Windows Domain. I run a Windows 2003 server. I can ping the OpenSUSE server from the Windows server.

Whenever I try to access my shared folders in OpenSUSE Windows returns with: "No network provider accepted the given network path". That is either when I enter the ip-address or the server name.

When I try to access my shared folders on OpenSUSE there is no problem at all.

I have been googling this for a while but no luck so far.

As you can see my smb.conf file is pretty rusty, I've been adding alot of stuff that I've googled and most of it is probably incorrect. :P


smb.conf
[global]
dns proxy = no
log file = /var/log/samba/%m.log
load printers = no
server string = Samba Server
socket options = TC_NODELAY SO_SNDBUF=8192 SO_RCVBUF=8192
workgroup = 90131AVENTUS
realm = 90131AVENTUS.LOCAL
security = ADS
OS level = 34 (20?)
domain logons = yes
encrypt password = yes
# domain master = Yes
# preferred master = Yes
max log size = 50
winbind uid = 10000-20000
winbind gid = 10000-20000
enhanced browsing = no
winbind use default domain = yes
winbind refresh tickets = yes
winbind offline login = yes
wins support = yes
usershare max shares = 100
template shell = /bin/bash
template homedir = /home/%D/%U
usershare allow guests = yes
passdb backend = smbpasswd
map to guest = Bad User
include = /etc/samba/dhcp.conf
# logon path = \\%L\profiles\%U
# logon home = \\%L\%U\.9xprofile
# logon drive = P:

[homes]
comment = Home Directories
valid users = %S, %D%w%S
browseable = yes
path = /home/%D/%U
read only = no
writeable = yes
inherit acls = yes

[printer]
comment = printer
path = /var/tmp
printable = yes
browseable = yes

[profiles]
comment = Network Profiles Share
path = /srv/samba/profiles
read only = no
store dos attributes = yes
create mask = 0600
directory mask = 0700
browseable = no
hide files = /desktop.ini/outlook*.Ink/*Briefcase*/

[Userprofiles$]
path = /home/Userprofiles
guest ok = Yes

[USERSHARES]
path = /var/lib/samba/usershares
guest ok = yes