Find the answer to your Linux question:
Results 1 to 3 of 3
Hi there I have been running 11.4 upgraded to 12.1 which ran reasonably well. Today I went to do a clean install from Live USB and I have a problem. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    95

    Installing a bootloader in SuSE 12.1


    Hi there

    I have been running 11.4 upgraded to 12.1 which ran reasonably well. Today I went to do a clean install from Live USB and I have a problem. The USB boots and runs fine, and it has installed what looks like a complete OS, however, it hasn't installed the bootloader correctly.

    I have navigated the /boot partition via the terminal and there is a grub installation on there, however, the BIOS can't boot the drive - I get "Operating System Error" when I try to boot from it, similar to the "invalid disk, please insert system disk" you would get if there was a non-bootable floppy in the drive

    How do I get the BIOS seeing grub? I guess I need to edit the MBR or something but I have no idea how?

    I have 12.1 Live KDE on a USB3 flash drive to work from

    Cheers
    Jonny

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Just to clarify, you had a bootable usb with Opensuse 12.1 on it and used it to install Opensuse to ??, an internal hard drive? on your Desktop computer? your laptop? an external drive?

    How did you navigate to the /boot directory? Did you create a separate /boot partition during the isntallation? Did you mount the partition on the hard drive?

    Did you change the boot priority in the BIOS back to boot first from your hard drive?

    It might be best to go to this site, download the bootinfoscript and run it to post the results.txt file here to get help. It will show drive/partition information as well as the location of boot files:

    SourceForge.net: Boot Info Script - Project Web Hosting - Open Source Software

  3. #3
    Just Joined!
    Join Date
    Mar 2007
    Posts
    95
    Hi

    thanks for the quick reply

    Its a PC, it was running 11.4 from HDD, then I used Yast to upgrade it to 12.1 which worked. I ran that for a week to make sure it was what I wanted to use

    Downloaded KDE Live 12.1 and installed onto USB flash drive using method on suse downloads site. Booted from that fine, rebooted, chose install and installed fine.

    Installation was done to an interal HDD, one of 3. I installed Suse to HDD1 (sdb2) and that is where the problems have come from.

    To mount the /boot I went into the live KDE and then used mount /dev/sdb2 /mnt/ and just navigated the entire file system from there, not the cleanest way but I could read the entire contents of the /boot

    Just tried to reinstall it again and fiddle with the BIOS and I can see the problem, the BIOS boots HDD1, Suse has installed onto HDD1, but the bootloader has been put onto the MBR of HHD0, I have no idea why that is or if it should behave like that.

    I can boot into an OS now by telling the BIOS to boot the "wrong" drive, which will work until that drive fails or is removed, can I copy its MBR over? Is this easy to correct or should I just physically swap the cable on HDD0 and HDD1 and reinstall?

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •