Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2011

    LibreCAD(QCAD) for SLED11 SP1

    Hello all, first time caller, long time listener

    New to Linux as of 2 months ago, minimal programming knowledge, SLED11 SP1 came with my machine so I thought I would give it a shot. I do have an engineering background, so I am loving the challenge! I am hoping that SLED is in the SUSE category and that I am posting this in the right spot

    Anyway, being an engineer, I am obviously looking for a good CAD program for Linux. I found two that are promising, LibreCad and QCad(it actually seems as though they are versions of each other, but that's irrelevant). My problem is that when I go to download the .rpm for LibreCad, which I would prefer, there isn't a build for SLED11.1, which I'm running. There's Fedora, Mandriva, openSUSE 11.3, etc.

    I obviously realized I don't have these so tried their option, "source package for all distributions - src.rpm" where I used YaST to run it and got the following error:

    [PK_TMP_DIR|dir:///var/tmp/TmpDir.eSDj0q] Repository already exists.

    I have received 'repository exists' errors before, so I tried the fix I learned:

    sudo zypper rr 2
    sudo zypper rr 1
    sudo zypper clean -a
    sudy zypper ref

    after which I tried to install again, and got the following error:

    [PK_TMP_DIR|dir:///var/tmp/TmpDir.fTvkCP] Repository already exists.

    sooooo ya...haha, a few questions...

    1) Am I just trying to install the incorrect file? This was the only option that made sense, unless I went to "older versions .rc3 & .rc4"
    2) What am I doing incorrectly to install the file I have?
    3) Am I not cleaning the repository properly?
    4) Should I find a way to install it without YaST?

    I know y'all like detailed questions, hope that's enough! Thanks guys!!

  2. #2
    I've been using Linux since the early 90's because I need Unix to run a free GIS program, GRASS, developed by the military. I haven't looked back and have found it extremely robust and has met all my needs. Be patient at times because it may take some work, albeit it is a piece of cake nowadays.

    To answer your question, I have been using Dassult System's Draft Sight in Ubuntu 11 and Mint 12. (see It isn't an open source program, but they do have a free version for Linux. I have found it to be super, and have recommended it to several FS engineers who run AutoCad at work and they have been impressed too.

    Rob St. John

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts