Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
Like Tree1Likes
Atreyu. Glad to get support from you!!! Concering point 1 and 2, I will try to enable on suse soon. Also thanks for the advanced tips. I so much appreciated ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jan 2012
    Posts
    11

    Atreyu. Glad to get support from you!!!
    Concering point 1 and 2, I will try to enable on suse soon. Also thanks for the advanced tips.
    I so much appreciated what you've done here.

    Jeff

  2. #12
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    np.

    i just thought of something else. Those other two ftp daemons that you stopped might be configured to autostart upon reboot, so to be safe, you ought to disable them outright. These commands (run as root) should do it, i think:

    Code:
    chkconfig pure-ftp off
    Code:
    chkconfig xinetd off
    Note that xinetd controls more than just that second vsftpd daemon. You can run this command to see which daemons are configured to run:

    Code:
    grep disable.*no$ /etc/xinetd.d/*
    If it lists any daemons that you do in fact want running (besides vsftpd which you'll control elsewhere), post that back here.

    Finally, make sure that the /etc/init.d/vsftpd is configured to autostart:

    Code:
    chkconfig vsftpd on

  3. #13
    Just Joined!
    Join Date
    Jan 2012
    Posts
    11
    atreyu, the reply is quite a bit late...
    I typed the command as below;

    chkconfig pure-ftp off
    chkconfig xinetd off
    grep disable.*no$ /etc/xinetd.d/*
    chkconfig vsftpd on

    I also attached the result as image file.
    chkconfig_result.JPG

    *In command grep disable.*no$ /etc/xinetd.d/*, how do I understand the grammar(?) of [disable.*no$] such as * and no$.
    ** If I would like to run vsftp in xinetd not init.d, how can I do that?

    Best Regards
    Jeff D. LEE

  4. #14
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    If you want to control vsftpd via xinetd:
    1. set disable = no in the file /etc/xinetd.d/vsftpd
    2. disable the vsftpd script in /etc/init.d:
    Code:
    chkconfig vsftpd off
    3. make sure xinetd is on:
    Code:
    chkconfig xinetd on
    If you want to control vsftpd via the script in /etc/init.d and not from xinetd:
    1. set disable = yes in the file /etc/xinetd.d/vsftpd
    2. enable the vsftpd script in /etc/init.d:
    Code:
    chkconfig vsftpd on
    again, the fact that you have both /etc/xinetd.d/vsftpd and /etc/init.d/vsftpd is very odd. Did you put one of them there manually? If you have rpm, try these commands:

    Code:
    rpm -qf /etc/xinetd.d/vsftpd
    rpm -qf /etc/init.d/vsftpd
    also, you have a typo in your grep command (diable instead of disable).

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •