Find the answer to your Linux question:
Results 1 to 2 of 2
Hi there I am experiancing slow (unusable) USB2 in Suse 12.1, I am using a USB2 card reader and 45MB/s CF card and getting read speeds of 900KB/s with dolphin. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    95

    Slow USB transfer speeds


    Hi there

    I am experiancing slow (unusable) USB2 in Suse 12.1, I am using a USB2 card reader and 45MB/s CF card and getting read speeds of 900KB/s with dolphin. USB, reader and card all work at expected speed in windows. What can I do to fix this?

    Not sure if this helps -
    Code:
    jonny@linux-6ava:~> dmesg | grep EHCI
    [    1.750334] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
    [    1.750432] ehci_hcd 0000:00:12.2: EHCI Host Controller
    [    1.750465] ehci_hcd 0000:00:12.2: applying AMD SB700/SB800/Hudson-2/3 EHCI dummy qh workaround
    [    1.756091] ehci_hcd 0000:00:12.2: USB 2.0 started, EHCI 1.00
    [    1.756116] usb usb1: Product: EHCI Host Controller
    [    1.756394] ehci_hcd 0000:00:13.2: EHCI Host Controller
    [    1.756407] ehci_hcd 0000:00:13.2: applying AMD SB700/SB800/Hudson-2/3 EHCI dummy qh workaround
    [    1.762083] ehci_hcd 0000:00:13.2: USB 2.0 started, EHCI 1.00
    [    1.762109] usb usb2: Product: EHCI Host Controller
    [    1.762386] ehci_hcd 0000:00:16.2: EHCI Host Controller
    [    1.762400] ehci_hcd 0000:00:16.2: applying AMD SB700/SB800/Hudson-2/3 EHCI dummy qh workaround
    [    1.768084] ehci_hcd 0000:00:16.2: USB 2.0 started, EHCI 1.00
    [    1.768108] usb usb3: Product: EHCI Host Controller
    Code:
    linux-6ava:/home/jonny # lsusb
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 002: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical
    Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 009 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 007 Device 002: ID 0dda:2026 Integrated Circuit Solution, Inc. USB2.0 Card Reader
    Here Bus 007 is shown as a USB1.1 hub? Is this correct because it is actually a USB 2 port on the front of an Antec Case? Infact, I do not believe I have ANY usb 1 ports

    Thanks
    Jonny

  2. #2
    Just Joined!
    Join Date
    Jan 2012
    Posts
    1
    Experiencing the exact same thing. My system is set up for Tumbleweed and I get the impression it happened after a recent update. I'm very sure the transfer rate was much better post initial installation.

    Quote Originally Posted by Jonny88 View Post
    Hi there

    I am experiancing slow (unusable) USB2 in Suse 12.1, I am using a USB2 card reader and 45MB/s CF card and getting read speeds of 900KB/s with dolphin. USB, reader and card all work at expected speed in windows. What can I do to fix this?

    Not sure if this helps -
    Code:
    jonny@linux-6ava:~> dmesg | grep EHCI
    [    1.750334] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
    [    1.750432] ehci_hcd 0000:00:12.2: EHCI Host Controller
    [    1.750465] ehci_hcd 0000:00:12.2: applying AMD SB700/SB800/Hudson-2/3 EHCI dummy qh workaround
    [    1.756091] ehci_hcd 0000:00:12.2: USB 2.0 started, EHCI 1.00
    [    1.756116] usb usb1: Product: EHCI Host Controller
    [    1.756394] ehci_hcd 0000:00:13.2: EHCI Host Controller
    [    1.756407] ehci_hcd 0000:00:13.2: applying AMD SB700/SB800/Hudson-2/3 EHCI dummy qh workaround
    [    1.762083] ehci_hcd 0000:00:13.2: USB 2.0 started, EHCI 1.00
    [    1.762109] usb usb2: Product: EHCI Host Controller
    [    1.762386] ehci_hcd 0000:00:16.2: EHCI Host Controller
    [    1.762400] ehci_hcd 0000:00:16.2: applying AMD SB700/SB800/Hudson-2/3 EHCI dummy qh workaround
    [    1.768084] ehci_hcd 0000:00:16.2: USB 2.0 started, EHCI 1.00
    [    1.768108] usb usb3: Product: EHCI Host Controller
    Code:
    linux-6ava:/home/jonny # lsusb
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 002: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical
    Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 009 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 007 Device 002: ID 0dda:2026 Integrated Circuit Solution, Inc. USB2.0 Card Reader
    Here Bus 007 is shown as a USB1.1 hub? Is this correct because it is actually a USB 2 port on the front of an Antec Case? Infact, I do not believe I have ANY usb 1 ports

    Thanks
    Jonny

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •