Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
Tethering may have something to do with it, because the tethering manager app on my phone crashes every few minutes sine the Gingerbread upgrade....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux User sgosnell's Avatar
    Join Date
    Oct 2010
    Location
    Baja Oklahoma
    Posts
    488

    Tethering may have something to do with it, because the tethering manager app on my phone crashes every few minutes sine the Gingerbread upgrade.

  2. #12
    Just Joined!
    Join Date
    Nov 2006
    Location
    near Berea, Kentucky (in a tipi)
    Posts
    47

    SOLVED!: Android Gingerbread mass storage on Linux

    Okay, here's what I found (and I consider this solved):

    The problem was not due to EHCI (which was doing exactly as it should).

    The problem was not with scsi generic (which wasn't doing anything).

    The problem was with usb_modeswitch (which is not in error.)

    It's just that my phone (Samsung M580 Replenish) has the same idVendor ("04e8") and idProduct ("f000") as Samsung U209 modem. Usb_modeswitch was doing just as it should (had my device been a modem) and telling the phone to switch off mass storage and be a modem. Commenting that line in /lib/udev/rules.d/40-usb_modeswitch.rules prevents usb_modeswitch from acting on the device when it's plugged in.

    Now dmesg looks like:
    [ 7870.269093] usb 1-7: new high-speed USB device number 4 using ehci_hcd
    [ 7870.385849] usb 1-7: New USB device found, idVendor=04e8, idProduct=f000
    [ 7870.385856] usb 1-7: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 7870.385863] usb 1-7: Product: Samsung Android USB Device
    [ 7870.385868] usb 1-7: Manufacturer: SAMSUNG Electronics Co., Ltd.
    [ 7870.385874] usb 1-7: SerialNumber: M580fa8f4dc4
    [ 7870.387802] scsi2 : usb-storage 1-7:1.0
    [ 7871.389049] scsi 2:0:0:0: Direct-Access SAMSUNG SPH-M580 Card 0100 PQ: 0 ANSI: 2
    [ 7871.389513] sd 2:0:0:0: Attached scsi generic sg2 type 0
    [ 7871.394213] sd 2:0:0:0: [sdb] Attached SCSI removable disk
    [ 9694.185950] sd 2:0:0:0: [sdb] 15515648 512-byte logical blocks: (7.94 GB/7.39 GiB)
    [ 9694.402982] sd 2:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
    [ 9694.631248] sdb:

    I added this line to /etc/fstab
    /dev/disk/by-id/usb-SAMSUNG_SPH-M580_Card_M580fa8f4dc4-0:0 /mnt/Android vfat users,noatime,auto 0 0

    I also created /mnt/Android/

    Now I can mount and access the SDcard again:
    mount /mnt/Android

    Thanks everyone!
    After
    Last edited by polypagan; 01-23-2012 at 07:30 PM. Reason: hex looked like emoticon!

  3. #13
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Nice! Thanks for posting your solution.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  4. #14
    Just Joined!
    Join Date
    Nov 2006
    Location
    near Berea, Kentucky (in a tipi)
    Posts
    47

    Two corrections...

    First, that /etc/fstab line should read noauto, rather than auto. Else Linux fails to boot waiting for Android SDcard to be available!

    Secondly, *sometimes* 'mount /mnt/Android' fails saying:
    no media on /dev/sdb

    In that case, 'mount /dev/sdb' works fine (?! can anyone explain that?)

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •