Find the answer to your Linux question:
Results 1 to 8 of 8
Hey there. I'm beginner in Linux, so maybe that's an easy question to solve. I'm trying to install the open source CFD OpemFOAM in my notebook. It har the Suse ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2012
    Location
    Modena - Italy
    Posts
    3

    OpenFOAM on SUSE 11.4 - Installing problems


    Hey there. I'm beginner in Linux, so maybe that's an easy question to solve. I'm trying to install the open source CFD OpemFOAM in my notebook. It har the Suse 11.4. When I try to follow the steps given in the OpenFOAM site. I get stucked with the installation of my mpi. If I try to install the repositories science, appears that already I have it. I checked at YAST, and put the prioroty with 98. Then I try to install the mpi version 1.3.2, but appears that there is no source for it.

    germanoh1aaalinux-25va:~> sudo zypper in openmpi=1.3.2
    Retrieving repository 'PK_TMP_DIR' metadata [done]
    Error building the cache:
    [|] Repository type can't be determined.
    Warning: Disabling repository 'science' because of the above error.
    Loading repository data...
    Reading installed packages...
    'openmpi=1.3.2' not found in package names. Trying capabilities.
    No provider of 'openmpi = 1.3.2' found.
    Resolving package dependencies...


    The next step should be to find what version of mpi I have, so I had to typo mpirun --version, but appears there is no lamd running. So I typed lamboot, appeared:

    LAM 7.1.4/MPI 2 C++/ROMIO - Indiana University

    then I try the mpi version

    germanoh1aalinux-25va:~> mpirun --version
    -----------------------------------------------------------------------------
    Synopsis: mpirun [options] <app>
    mpirun [options] <where> <program> [<prog args>]

    Description: Start an MPI application in LAM/MPI.

    Notes:
    [options] Zero or more of the options listed below
    <app> LAM/MPI appschema
    <where> List of LAM nodes and/or CPUs (examples
    below)
    <program> Must be a LAM/MPI program that either
    invokes MPI_INIT or has exactly one of
    its children invoke MPI_INIT
    <prog args> Optional list of command line arguments
    to <program>

    Options:
    -c <num> Run <num> copies of <program> (same as -np)
    -client <rank> <host>:<port>
    Run IMPI job; connect to the IMPI server <host>
    at port <port> as IMPI client number <rank>
    -D Change current working directory of new
    processes to the directory where the
    executable resides
    -f Do not open stdio descriptors
    -ger Turn on GER mode
    -h Print this help message
    -l Force line-buffered output
    -lamd Use LAM daemon (LAMD) mode (opposite of -c2c)
    -nger Turn off GER mode
    -np <num> Run <num> copies of <program> (same as -c)
    -nx Don't export LAM_MPI_* environment variables
    -O Universe is homogeneous
    -pty / -npty Use/don't use pseudo terminals when stdout is
    a tty
    -s <nodeid> Load <program> from node <nodeid>
    -sigs / -nsigs Catch/don't catch signals in MPI application
    -ssi <n> <arg> Set environment variable LAM_MPI_SSI_<n>=<arg>
    -toff Enable tracing with generation initially off
    -ton, -t Enable tracing with generation initially on
    -tv Launch processes under TotalView Debugger
    -v Be verbose
    -w / -nw Wait/don't wait for application to complete
    -wd <dir> Change current working directory of new
    processes to <dir>
    -x <envlist> Export environment vars in <envlist>

    Nodes: n<list>, e.g., n0-3,5
    CPUS: c<list>, e.g., c0-3,5
    Extras: h (local node), o (origin node), N (all nodes), C (all CPUs)

    Examples: mpirun n0-7 prog1
    Executes "prog1" on nodes 0 through 7.

    mpirun -lamd -x FOO=bar,DISPLAY N prog2
    Executes "prog2" on all nodes using the LAMD RPI.
    In the environment of each process, set FOO to the value
    "bar", and set DISPLAY to the current value.

    mpirun n0 N prog3
    Run "prog3" on node 0, *and* all nodes. This executes *2*
    copies on n0.

    mpirun C prog4 arg1 arg2
    Run "prog4" on each available CPU with command line
    arguments of "arg1" and "arg2". If each node has a
    CPU count of 1, the "C" is equivalent to "N". If at
    least one node has a CPU count greater than 1, LAM
    will run neighboring ranks of MPI_COMM_WORLD on that
    node. For example, if node 0 has a CPU count of 4 and
    node 1 has a CPU count of 2, "prog4" will have
    MPI_COMM_WORLD ranks 0 through 3 on n0, and ranks 4
    and 5 on n1.

    mpirun c0 C prog5
    Similar to the "prog3" example above, this runs "prog5"
    on CPU 0 *and* on each available CPU. This executes
    *2* copies on the node where CPU 0 is (i.e., n0).
    This is probably not a useful use of the "C" notation;
    it is only shown here for an example.

    Defaults: -c2c -w -pty -nger -nsigs
    ------------------------------------------

    I tried to skip these steps and install the programns, so:
    sudo rpm -i (ww....)openfoam.org/download/suse/11.4/x86_64/OpenFOAM-scotch-5.1.12-1.x86_64.rpm]Download OpenFOAM - The Open Source CFD Toolbox from SourceForge.net[/url]
    sudo rpm -i w....openfoam.org/download/suse/11.4/x86_64/OpenFOAM-ParaView-3.12.0-1.x86_64.rpm]Download OpenFOAM - The Open Source CFD Toolbox from SourceForge.net[/url]
    sudo rpm -i w....openfoam.org/download/suse/11.4/x86_64/OpenFOAM-2.1.0-1.x86_64.rpm]Download OpenFOAM - The Open Source CFD Toolbox from SourceForge.net[/url]

    but after the last one, appears:
    germanoh1aaalinux-25va:~> sudo rpm -i w...openfoam.org/download/suse/11.4/x86_64/OpenFOAM-2.1.0-1.x86_64.rpm]Download OpenFOAM - The Open Source CFD Toolbox from SourceForgedot net
    error: Failed dependencies:
    libopen-pal.so.0()(64bit) is needed by OpenFOAM-2.1.0-1.x86_64
    libopen-rte.so.0()(64bit) is needed by OpenFOAM-2.1.0-1.x86_64
    ...

    so... I don't know what to do.... x)

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    You are getting those libopen-pal.so errors b/c you haven't been able to download the newer openmpi, i am guessing. it sounds like something might be wrong with one of your repo files. i don't have SUSE so I can't give you specific instructions. Looking at the OpenFOAM website instructions, did you run this command, and did it complete successfully?

    Code:
    sudo zypper ar http://download.opensuse.org/repositories/science/openSUSE_11.4 science

  3. #3
    Just Joined!
    Join Date
    Feb 2012
    Location
    Modena - Italy
    Posts
    3

    OpenFOAM on SUSE 11.4 - Installing problems

    I believe that in the first time yes.. It did... but know when I try it says that such repository already exists...

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Okay, let's look at your repo files (they are configuration files for yum/zypper, etc.). Run this command to look for repo files that contain the science repo:
    Code:
    find /etc/ -type f -name '*.repo' -exec grep -L science {} \;
    Post the content of the repo file(s) found, and maybe something in there will be obvious.

    If that returns no files found, try this one instead (looks for any repo files):
    Code:
    find /etc/ -type f -name '*.repo'
    Btw, if there are any SUSE pros out there, chime in! I'm stumbling around here...

  5. #5
    Just Joined!
    Join Date
    Feb 2012
    Location
    Modena - Italy
    Posts
    3
    Well... I tried the first one and this appeared...
    linux-25va:/home/germanoh1 # find /etc/ -type f -name '*.repo' -exec grep -L science {} \;
    /etc/zypp/repos.d/repo-oss.repo
    /etc/zypp/repos.d/PK_TMP_DIR.repo
    /etc/zypp/repos.d/repo-source.repo
    /etc/zypp/repos.d/repo-debug.repo
    /etc/zypp/repos.d/repo-non-oss.repo
    /etc/zypp/repos.d/openSUSE-11.4-11.4-0.repo
    /etc/zypp/repos.d/repo-debug-update.repo
    /etc/zypp/repos.d/Updates-for-openSUSE-11.4-11.4-0.repo
    linux-25va:/home/germanoh1 #

    I really don`t know if its right or not...

    I`m having problems with another instalations. My skype, for ex, was installed but not worked, so I tried to unistall via YAst. Now that I try to install again, appears the error [PK_TMP_DIR|dir:///var/tmp/TmpDir.S94SLa] Repository already exists.

  6. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by germanoh1 View Post
    Well... I tried the first one and this appeared...
    linux-25va:/home/germanoh1 # find /etc/ -type f -name '*.repo' -exec grep -L science {} \;
    /etc/zypp/repos.d/repo-oss.repo
    /etc/zypp/repos.d/PK_TMP_DIR.repo
    /etc/zypp/repos.d/repo-source.repo
    /etc/zypp/repos.d/repo-debug.repo
    /etc/zypp/repos.d/repo-non-oss.repo
    /etc/zypp/repos.d/openSUSE-11.4-11.4-0.repo
    /etc/zypp/repos.d/repo-debug-update.repo
    /etc/zypp/repos.d/Updates-for-openSUSE-11.4-11.4-0.repo
    linux-25va:/home/germanoh1 #

    I really don`t know if its right or not...

    I`m having problems with another instalations. My skype, for ex, was installed but not worked, so I tried to unistall via YAst. Now that I try to install again, appears the error [PK_TMP_DIR|dir:///var/tmp/TmpDir.S94SLa] Repository already exists.
    that seems like an awful lot of repos to be available that all have science in them. are you sure that was from the first command?

    Try this to clean up yum:
    Code:
    yum clean all
    then just list your repos that are enabled:
    Code:
    yum repolist
    then try installing openmpi and see if that worked.

    if not, then trying disabling all those zypper repos temporarily by moving them to a DISABLED dir, e.g.:
    Code:
    mkdir /etc/zypp/repos.d/DISABLED
    mv /etc/zypp/repos.d/*.repo /etc/zypp/repos.d/DISABLED
    then enable them one by one, by moving them one at a time back into the original dir (/etc/zypp/repos.d/).

    Edit: before you move them, you can run this command to see which repos belong to which rpm packages:
    Code:
    rpm -qf /etc/zypp/repos.d/*.repo
    Last edited by atreyu; 02-06-2012 at 12:39 PM. Reason: which rpm owns which repo file

  7. #7
    Just Joined!
    Join Date
    Apr 2012
    Location
    Tokyo
    Posts
    2
    Hi

    I also have the same problem.
    I followed the installation guide on the openfoam website.

    First I executed this command:
    Code:
    sudo zypper ar h-t-t-p://download.opensuse.org/repositories/science/openSUSE_11.4 science
    and it returned:
    Code:
    Adding repository 'science' [done]
    Repository 'science' successfully added
    Enabled: Yes
    Autorefresh: No
    URI: h-t-t-p://download.opensuse.org/repositories/science/openSUSE_11.4
    the problem occurred when I executed this command:
    Code:
    sudo zypper in openmpi=1.3.2
    it returned:
    Code:
    Retrieving repository 'PK_TMP_DIR' metadata [done]
    Building repository 'science' cache [done]
    Loading repository data...
    Reading installed packages...
    'openmpi=1.3.2' not found in package names. Trying capabilities.
    No provider of 'openmpi = 1.3.2' found.
    Resolving package dependencies...
    
    Nothing to do.
    I tried to uninstall the installed openmpi-1.2.8 and then repeat the above steps, but the same problem occurred..

    P.S. I got this error message when posting this reply -> "You are only allowed to post URLs (http, ftp, @) to other sites after you have made 15 posts or more."

  8. #8
    Just Joined!
    Join Date
    Apr 2012
    Location
    Tokyo
    Posts
    2
    The problem has been solved, please check here:

    link.jpg

    #You are only allowed to post URLs (http, ftp, @) to other sites after you have made 15 posts or more.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •