Find the answer to your Linux question:
Results 1 to 3 of 3
Hi there! I am using SuSE 11.3 and have the following problem. I'm trying to connect to a router via the wireless port on my Toshiba laptop. (I'm not using ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    27

    Question Wireless connection to router works withWPA but not without encryption


    Hi there!

    I am using SuSE 11.3 and have the following problem. I'm trying to connect to a router via the wireless port on my Toshiba laptop. (I'm not using NetworkManager, I've set it up with the ifup/ifdown method.)

    If I'm setting up the router such that it requires WPA2/AES authentication (called WPA/PSK in the Linux settings), everything works fine. But if I set the security mode to "disabled" on the router and the authentication method to "No Encryption" in yast, it cannot connect.

    I've tried this with 3 routers actually (2 different Linksys routers and a TPLink) and the same thing happened. Thus it seems that I will probably have to set up something in a different way.


    Does anyone have any idea what/how?


    Thanks,
    Agoston

    P.S.: Please don't advise me to use NetworkManager. First I started with that back when I was connecting through regular cable (i.e., using eth0) and for a few days it worked, then never again. I've read afterwards that it is considered highly unreliable and I wouldn't like to start having problems with it now.

    P.S.2: Neither should you tell me to "use WPA then", because right now I'm at a place where I cannot change the router settings but have to adjust the ones on my own SuSE instead.

  2. #2
    Linux Newbie reginaldperrin's Avatar
    Join Date
    Oct 2010
    Location
    Christchurch, New Zealand
    Posts
    123
    Hi there,
    I hope I can offer a few suggestions based on what you have stated.
    From the sounds of it: "I've tried this with 3 routers actually (2 different Linksys routers and a TPLink) and the same thing happened", the problem is not at the router end.
    I would re-examine the device settings for the Toshiba laptop. I wouldn't be surprised if there wasn't a setting which always tried to force an encrypted connection.
    This would explain why a non-encrypted connection won't work, and it would account for the multiple routers above.
    Failing all of that, go back to basics and re-setup from scratch. It is easy to make a mistake which has far-reaching consequences, and one which you can't easily see.

    Hope this helps.

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Posts
    27

    Thumbs up SOLVED: Wireless conn. to router works w/WPA but not w/out encryption

    Hi,

    thanks for your hints! In the meantime I've found the solution (or rather a workaround...?)

    iwconfig wlan0 essid <essid-of-the-router>
    # and this every time ifup wlan0 is called or even when the machine is woken up from sleep mode


    Cheers,
    Agoston
    Last edited by agostonbejo; 02-11-2012 at 02:41 PM. Reason: case is solved

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •