Find the answer to your Linux question:
Results 1 to 3 of 3
Dear SUSE Linux Expert, Can you help me boot my computer, I am receiving this error message on my screen UNEXPECTED INCONSISTENCY: RUN fsck manually fsck failed for at least ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2011
    Posts
    1

    Question UNEXPECTED INCONSISTENCY: RUN fsck manually


    Dear SUSE Linux Expert,

    Can you help me boot my computer, I am receiving this error message on my screen UNEXPECTED INCONSISTENCY: RUN fsck manually

    fsck failed for at least one filesystem (not / y)
    Please repair manually and reboot.
    The root file system is already mounted read-write.

    I really have no idea what to do, please i need your help.

    thanks

  2. #2
    Linux Newbie hans51's Avatar
    Join Date
    May 2011
    Posts
    136
    the most common reason why you may have this error is that you MAY have ONE or several partitions / drives (USB ?) that are NOT connected to your booting machine but are listed in your /etc/fstab
    if a drive is missing you may manually delete that entry in your /etc/fstab (or connect missing drive)

    all partitions or drives listed in /etc/fstab are expected to be present/connected on boot, else you have this error
    some of the external drives have an ON/OFF switch
    make sure any external drive is ON and connected

    if you still have the same error
    then you have to do a manual file system check
    file system errors can occur when you lose power of just power OFF your machine while system is writing and data damage has occurred

    the use of fsck is easy you just have to know what exact file system you have = ext3/ext4 or ?
    see:
    SDB:Fsck: Unexpected Inconsistency - openSUSE
    How to check/repair (fsck) filesystem after crash or power-outage | Linux Poison

  3. #3
    Just Joined!
    Join Date
    Sep 2012
    Posts
    1
    Hello.

    If you have an external drive OFF or not connected (i.e. an USB disk), but you don't want to delete its entry in your /etc/fstab, you can edit your fstab file, so the system doesn't check this filesystem and doesn't hang up.

    Example.

    You have this line in fstab, for the USB external disk:
    /dev/sdb1 /media/LINUX auto rw,nosuid,nodev,sync,data=ordered,auto,user,exec 1 2

    It says that /media/LINUX will be backed up and checked with fsck during system start up. At the end on the line, number "1" is the backup option, and number "2" is the fsck option.

    You may desire to change the line to:
    /dev/sdb1 /media/LINUX auto rw,nosuid,nodev,sync,data=ordered,auto,user,exec 0 0

    *Dump option uses the number to decide if a filesystem should be backed up. If it's zero, dump will ignore that filesystem.

    *fsck looks at the number in the last column to determine in which order the filesystems should be checked. If it's zero, fsck won't check the filesystem.

    Now the computer will start up well, on both situations: USB disk connected or disconnected.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •