Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I have a SLES linux server (11.1) where the "who" output is like this : userlogon pts/12 2012-06-01 14:55 (my.domain.com) I have another SLES linux server (also 11.1) where ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2012
    Posts
    2

    "who" command doesn't sho me FDQN. always IP address is shown


    Hi,

    I have a SLES linux server (11.1) where the "who" output is like this :

    userlogon pts/12 2012-06-01 14:55 (my.domain.com)

    I have another SLES linux server (also 11.1) where the who output is like this :


    userlogon pts/11 2012-06-01 13:52 (10.1.1.1)

    Where can I configure that always the FDQN is shown?
    (I tried with option --lookup but this doesn't help, still the IP address is shown)

    regards,

  2. #2
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    3,425
    Review the dns config in /etc/resolv.conf of that second maschine,
    and check, if there is the same nameserver as in the first machine and that the nameserver is reachable.
    You must always face the curtain with a bow.

  3. #3
    Just Joined!
    Join Date
    Jun 2012
    Posts
    2
    Hi,

    I have checked this. files on both machines are the same. DNS resolution works fine. (nslookup)
    problem is still there.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! dono725's Avatar
    Join Date
    Sep 2012
    Location
    NSW, Australia
    Posts
    28
    I didn't think nslookup worked in linux. I have never used the "who" command so I am not sure of the purpose. Is it suppose to show the FQDN of the local machine where the command is entered.
    Does the name server have a host record and a pointer for the client. have you tried the dig <hostname> and dig -x <ipaddress>. Make sure cache is flushed (the only way I know of doing this is the re-start machines)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •