Find the answer to your Linux question:
Results 1 to 2 of 2
Hello Guys, I have a SLED 11 (x86_64) and want to convert it to openSUSE 12. Is that doable and which are the steps? Code: henrik ~ 3 > cat ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2012
    Location
    Södra Prästholm, Luleå, Sweden
    Posts
    5

    Question Convert from SLED to openSUSE


    Hello Guys,

    I have a SLED 11 (x86_64) and want to convert it to openSUSE 12.
    Is that doable and which are the steps?

    Code:
    henrik ~ 3 > cat /etc/SuSE-brand 
    SLED
    VERSION = 11
    CO-BRANDS = SLE openSUSE
    henrik ~ 4 > cat /etc/SuSE-release 
    SUSE Linux Enterprise Desktop 11 (x86_64)
    VERSION = 11
    PATCHLEVEL = 0
    /Henrik

  2. #2
    Just Joined!
    Join Date
    Jul 2012
    Location
    Södra Prästholm, Luleå, Sweden
    Posts
    5

    Upgraded to openSUSE, remaining problems

    Quote Originally Posted by kankhenrik View Post
    Hello Guys,

    I have a SLED 11 (x86_64) and want to convert it to openSUSE 12.
    Is that doable and which are the steps?

    Code:
    henrik ~ 3 > cat /etc/SuSE-brand 
    SLED
    VERSION = 11
    CO-BRANDS = SLE openSUSE
    henrik ~ 4 > cat /etc/SuSE-release 
    SUSE Linux Enterprise Desktop 11 (x86_64)
    VERSION = 11
    PATCHLEVEL = 0
    /Henrik
    Hi again,

    I've tested the method from TechnoBlog: Convert SLES to OpenSUSE (chilipuppy.blogspot.se/2008/10/convert-sles-to-opensuse.html),
    to convert from SLED to openSUSE.
    I've downloaded openSUSE DVD-isos, för 11.2, 11.3, 11.4 and 12.1:
    - 11.2 The upgrade hanged for more than an hour, directly after my choice of upgrade.
    - 11.3 Not possible upgrading.
    - 11.4 Not possible upgrading.
    - 12.1 Upgraded, with new packages, default option. Had to solve four conflicts manually.

    I have at least one remaining problems and have made some workarounds:
    - Boot-entry in GRUB2 (Fedora 17), has made a workaround
    - The fstab, has made a workaround, maybe same problem as in GRUB2.
    - Missing /etc/sysconfig/sysctl, testing a workaround (copy of /etc/sysconfig/sysctl.rpmsave).
    - X doesn't start.

    Made an update from the openSUSE-repository, with 'zypper update' (yum can't run).
    More than 500 packages and nearly 1GB download.
    Didn't solve the known problems.

    Adjusted boot-entry:
    Code:
    # legacy_kernel   '/vmlinuz' '/vmlinuz' 'root=/dev/disk/by-id/ata-SAMSUNG_HD160JJP_S0DFJ10P122886-part2' 'resume=/dev/disk/by-id/ata-SAMSUNG_HD160JJP_S0DFJ10P122886-part1' 'splash=silent' 'showopts'
      legacy_kernel   '/vmlinuz' '/vmlinuz' 'root=/dev/sdb2' 'resume=/dev/sdb1' 'splash=silent' 'showopts'
    Adjusted fstab-entries:
    Code:
    #/dev/disk/by-id/ata-SAMSUNG_HD160JJP_S0DFJ10P122886-part1 swap                 swap       defaults              0 0
    #/dev/disk/by-id/ata-SAMSUNG_HD160JJP_S0DFJ10P122886-part2 /                    ext3       acl,user_xattr        1 1
    #/dev/disk/by-id/ata-SAMSUNG_HD160JJP_S0DFJ10P122886-part3 /boot                ext3       acl,user_xattr        1 2
    /dev/sdb1            swap                 swap       defaults              0 0
    /dev/sdb2            /                    ext3       acl,user_xattr        1 1
    /dev/sdb3            /boot                ext3       acl,user_xattr        1 2
    Appended a gzip:ed version of Xorg.0.log
    Errors in /var/log/Xorg.0.log (same errors in Xorg.[1-5].log):
    Code:
    [root@uw000140 log]# egrep -n '\(EE\)' Xorg.0.log
    15:    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    141:[    41.032] (EE) Failed to load /usr/lib64/xorg/modules/updates/extensions/libglx.so: /usr/lib64/xorg/modules/updates/extensions/libglx.so: undefined symbol: miInitVisualsProc
    142:[    41.032] (EE) LoadModule: Module glx does not have a glxModuleData data object.
    145:[    41.032] (EE) Failed to load module "glx" (invalid module, 0)
    148:[    41.032] (EE) Failed to load /usr/lib64/xorg/modules/updates/extensions/libdri.so: /usr/lib64/xorg/modules/updates/extensions/libdri.so: undefined symbol: miEmptyData
    149:[    41.032] (EE) LoadModule: Module dri does not have a driModuleData data object.
    152:[    41.032] (EE) Failed to load module "dri" (invalid module, 0)
    168:[    41.066] (EE) Failed to load /usr/lib64/xorg/modules/drivers/fglrx_drv.so: /usr/lib64/xorg/modules/drivers/fglrx_drv.so: undefined symbol: resVgaShared
    169:[    41.066] (EE) LoadModule: Module fglrx does not have a fglrxModuleData data object.
    172:[    41.066] (EE) Failed to load module "fglrx" (invalid module, 0)
    173:[    41.066] (EE) No drivers available.
    [root@uw000140 log]#
    I hope that someone has solutions for my problems.

    Thanks,
    Henrik
    Attached Files Attached Files

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •