Find the answer to your Linux question:
Results 1 to 6 of 6
Hello, I've a desktop system with Intel i5, 8GB ram, 2TB HDD. I've Windows 7 64bit OS installed as follows: System Reserved Space - 200MB C: - Windows 7 64 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    69

    Open Suse 11.2 unable to identify Windows 7 64bit partitions & mount


    Hello,

    I've a desktop system with Intel i5, 8GB ram, 2TB HDD. I've Windows 7 64bit OS installed as follows:
    System Reserved Space - 200MB
    C: - Windows 7 64 bit, 100GB
    D: - Media Drive, 1600GB
    O: - Raw (Logical drive) - 25GB

    When I put in SuseLinux and go to installation mode, it is identifying the drives but not specifying mount points. Should I go ahead with installation by manually specifying mount points as "C:\", "D:\" ?

    Please help.

    Greetings,
    Sun.

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    A little more detail would help. Do you have one physical hard drive? How many partitions? 2? 3? Is your Raw referring to a logical partition? It would be helpful if after you boot the Opensuse CD to the Desktop, you open a terminal and run the command: fdisk -l (lower case Letter L as root user) and post that information here. At what step do you start having problems? The first screen you should see is the Welcome screen with the License agreement, next would be time zone then a Suggested Partitioning Screen. What do you see there? You need to take a careful look at the Suggested Partitioning so that you do not format partitions you already have or install to the wrong partition. If the partitioning suggested is not what you want, you should have an Edit Partition tab at the bottom of that window which you need to open to change. You should get a new window and this is where you can make your changes. Highlight the free space and you should get options to make changes, filesystem type, mount point, etc.

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Posts
    69
    Hello Yancek,
    Many thanks for your reply. I did exactly the same, put in the OpenSuse DVD and boot from it. after the welcome screen and license agreement, at the suggested partitioning screen, it said, Linux can either not read the file system or the disk is not partitioned and asked me to edit it. Which is when, I moved to "edit partition". This is where I see the various harddisk partitions are present but no mount points.

    And yes, its a single physical hard drive. I have partitions as mentioned above, a system partition which windows by itself creates, a C with Windows system (NTFS) on it, D with Media (NTFS), and I created a partition "O" which is of format "RAW" and is termed as "logical drive".
    I would ideally like to install on the "RAW". But only worried if I have to specify mount points rather than it picking up by itself. My fear is, if it doesnt pick up by itself, it might not boot into Windows should I choose to boot into at a later time.

    Is that fine to manually specify boot points at this stage ?
    Many thanks for your help!

    Greetings,
    Sunsys.jpg

  4. #4
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    When you get to the Suggested Partitioning screen, you need to click on what you refer to as the "O" partition which will be called something else as that is not Linux nomenclature. It will probably be sda4 although the number may be different. The "sda" refers to the first hard drive. The number after it refers to the partition and your last post shows you have four partitions and I would expect your "O" partition would be the last one you created. If you are using an Opensuse Live CD where you boot to a Desktop and then click on the Install icon to start, click the Menu in the lower left and go to a terminal and login as root (type: su), then type this command: fdisk -l(Lower case Letter L in the command). This will output your partition information in Linux nomenclature which will be helpful.

    If your "O" partition ends up being correct, you would click it to highlight it then right-click and get several options, one of which is Edit. You would click Edit and you will get a new window where you can select to format and select the filesystem type (ext4) and mount point. Click the down arrow to the right of the tab below mount point and you should have several options. The first should be either a blank or "/" the forward slash which signifies the root of the filesystem. That is where you want to install Opensuse. You've already got your four primary partitions so I don't know if you will have a problem with not creating a swap. If you post the fdisk output it would be informative.

  5. #5
    Just Joined!
    Join Date
    Aug 2004
    Posts
    69
    Hello Yancek,

    Many thanks for your help!
    I did as you told. Although, my main problem was linux unable to load grub... I googled up a bit and found what is called EasyBCD. I notice that windows 7 has kept the MBR on a system reserve partition, which is why Linux is unable to load grub. I now boot via EasyBCD and have Windows & Linux successfully.

    Once again, many thanks for your help.
    Greetings,
    Sun

  6. #6
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    The Opensuse installer has a lot of options in regard to the bootloader which arent' obvious and I believe the default is to NOT install it to the master boot record which is what you report. Glad you got it working.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •