Find the answer to your Linux question:
Results 1 to 3 of 3
Hello Everyone, I am very new to the Linux world, and have never been to big into PC's or IT either. Please bear with me while I lay down the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2012
    Location
    South Africa
    Posts
    2

    Epson Thermal Receipt/Label Printer Issue.


    Hello Everyone,

    I am very new to the Linux world, and have never been to big into PC's or IT either. Please bear with me while I lay down the backdrop to my problem;

    Recently my dad took over a small local supermarket and needed a cheap and easy point of sale application.
    Having never more than informally dabbled in PC's and the like, I only know of, but not about, Linux.
    I did some research and after a week or so gave him openSUSE 12.1 on his laptop.(Dual booting either WinXP or openSUSE.)
    I managed to install LemonPOS 0.9.4 rc7 for him using Yast and configured mySQL 5.5 using the included .sql script from Sourceforge.
    He loves the software, he has been "live" in-store for almost a week now and cannot stop telling all and sundry about it. Since he is in his 50's and only really knew how to turn a PC on and check email, this is a small miracle.
    That is the backdrop, here's my problem:

    My dad has an Epson TM L60 dual purpose thermal receipt/label printer.
    It has an RS 232 connector and I have a USB to serial adaptor cable.
    I tried using CUPS and Yast to install the printer, but I cannot. I cannot find any help on the net either. (No, seriously, I even tried searching this site three times!! "installing thermal printer using usb to serial converter", "installing printer using usb to serial converter" & "usb to serial converter")
    Can anybody help me?
    My dad is really counting on me to help him since he thinks I suddenly woke up and became this computer guru, even though I play it down at every opportunity.
    I must stress that I am no PC whizz, but can get by and am capable of doing most things if given time and the instructions.

    Thanks and cheers.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,539
    Have you visited the Avasys web site that hosts Epson's "official" linux/cups drivers? Here is a link: Linux Driver | AVASYS CORPORATION
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Jul 2012
    Location
    South Africa
    Posts
    2

    Lightbulb

    Quote Originally Posted by Rubberman View Post
    Have you visited the Avasys web site that hosts Epson's "official" linux/cups drivers?]
    Hi Rubberman,

    Thanks for the link, I have only been on Epson's website, and various driver download sites that seem to have the exact same file as the Epson site.
    I'll try the Avasys site and report back.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •