Find the answer to your Linux question:
Results 1 to 7 of 7
Like Tree1Likes
  • 1 Post By atreyu
Hey all, I recently got OpenSUSE up and running, but I've been trying to connect to the internet. I've installed my necessary BCM drivers via the commands: Code: sudo zypper ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2012
    Posts
    10

    iwconfig thinks that wireless card is connected


    Hey all,

    I recently got OpenSUSE up and running, but I've been trying to connect to the internet. I've installed my necessary BCM drivers via the commands:
    Code:
    sudo zypper install b43-fwcutter
    sudo /usr/sbin/install_bcm43xx_firmware
    And the installation seemed to go fine, as the system now recognizes that I have a wireless card.

    The problem is when I go into network configuration and attempt to my router. The router is a pretty run-of-the-mill ATT 2WIRE router. I managed to connect to it using DHCP and a WEP-open with a passphrase enabled. In the device manager area, with the ethernet and wireless, it doesn't say that my wireless isn't connected, so I assumed that it was.

    However,
    Code:
    ping -c 3 google.com
    returns the good ol' unknown host error. Opening FireFox confirms that my computer isn't connected to the internet.

    Any tips? Thanks in advance.

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Perhaps it is a resolve issue? Look at /etc/resolv.conf and see if it is pointing back to your router's address. If so and still no go, find the DNS entries from your ISP and put those in there. Can you use secure shell (ssh) to another machine on your network? If so, I imagine it is a resolve issue. Check this /etc/resolv.conf for comparison...
    Code:
    # Generated by NetworkManager
    search myisp.net
    nameserver 123.456.789.12
    nameserver 234.567.890.23
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #3
    Just Joined!
    Join Date
    Jul 2012
    Posts
    10
    Thanks for your reply! Upon reboot, my wireless card now ceases to recognize that there are any networks about.

    I compared /etc/resolv.conf's, and it seems to be correct, though it only has two lines, as opposed to the three that your example has.

    I'm also using the ifup method, as opposed to Network Manager, as trying to start it with both
    Code:
    gnomesu nm-applet
    nm-applet
    fail, spitting out some warning messages.

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Have a look at this page. Lots of good info on the Broadcom wireless devices.

    http://linuxwireless.org/en/users/Drivers/b43/#openSUSE
    Linux Mint + IceWM Registered: #371367 New Members: click here

  6. #5
    Just Joined!
    Join Date
    Jul 2012
    Posts
    10
    All I see there are the BCM installation commands. I was under the impression that using those commands only allowed Linux to recognize the wireless card in the first place. I'll try running them again, just in case.

  7. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by green_meep View Post
    All I see there are the BCM installation commands. I was under the impression that using those commands only allowed Linux to recognize the wireless card in the first place. I'll try running them again, just in case.
    do you have a default gateway? you can check with

    Code:
    route -n
    it is usually the ip address of your (wireless) router/cable modem. if it is not there, you can do something like:

    Code:
    route add default gw 192.168.1.1 dev eth0
    you would substitute the right ip address and your ethernet adapter name, of course.

    this all assumes that your network adapter is up and configured with an appropriate ip address already.
    Dapper Dan likes this.

  8. #7
    Just Joined!
    Join Date
    Jul 2012
    Posts
    10
    Well, Dapper Dan was correct in realizing that my firmware was not installed properly. Here's how I did it, for those who stumble upon this thread with a similar problem:

    1. Set the YaST Network Settings to NetworkManager from ifup.
    2. Reboot (Can't believe I didn't try this!)
    3. nm-applet is now properly displayed in the system tray.
    4. I managed to get hold of a really long LAN cable and connected my computer temporarily to the internet, just so I could run the standard bcm openSUSE commands:
    Code:
    sudo zypper install b43-fwcutter
    sudo /usr/sbin/install_bcm43xx_firmware
    5. Connect as you would with pretty much any other major OS.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •