Find the answer to your Linux question:
Results 1 to 4 of 4
I've recently installed OpenSuse 12.1 on a new laptop, since I only need it for some low-level command-line stuff, I have installed it in text mode. Now, I'm calling a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2008
    Posts
    28

    OpenSuse 12 Text Mode clears screen before login


    I've recently installed OpenSuse 12.1 on a new laptop, since I only need it for some low-level command-line stuff, I have installed it in text mode.

    Now, I'm calling a script in boot.local that does a number of checks and outputs the results to stdout. One problem, however, just before I'm allowed to login, OpenSuse seems to decide that the entire screen should be cleared first, so I have maybe a hundredth of a second to actually see the results. Any idea how to prevent the clearing of my screen?

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,307
    you can grep the rc scripts for a "clear" command. it might be buried in a binary, though.

    or you could put a "sleep 5" after your commands have run in the boot.local file.

    or you could tee the output, so it gets sent to STDOUT and to file, and you can look at the file after the fact, e.g.:

    Code:
    /my/prog | tee /tmp/prog.log

  3. #3
    Just Joined!
    Join Date
    Nov 2008
    Posts
    28
    already searched for clear commands in the rc scripts, nothing there. Sleep commands seem to be completely ignored (perhaps the script is started parallel?). Also, having to review a log after every boot, not really an option.

    Incidently, there is something else that seems off. I've worked with OpenSUSE 10.3 and OpenSUSE 11 before and I remember that I always got a whole load of messages scrolling all over the screen about detecting devices and starting services, none of those message seem to be appearing anymore. When Linux start, I seem to be getting maybe a screenful of messages before it clears, none of it even seem to mention starting services or anything else that I am used to. Could this be linked to my problem?

  4. #4
    Just Joined!
    Join Date
    Nov 2008
    Posts
    28
    little update, I've been looking into the boot messages thing and found the splash=silent option, setting this to splash=verbose made at least the messages appear again. However, I can also see why this is standard set to silent, apparantly the login prompt appears before the boot sequence really finishes (I get messages about the network still being set up, while the prompt appears) and the screen is still being cleared. I've already tried setting RUN_PARALLEL to no in /etc/sysconfig/boot, to at least get the login only after all the boot business is done, no luck on that front. Anyone?

    [EDIT]
    Yet another update here, apparantly the running of my script and the starting of services are somehow run parallel, but the login prompt does actually wait for my script to finish. That means that pausing for a few seconds should actually be good for me. However, it appears that the output of my script does not appear. None of my echo instructions seem to do anything at all. Anyone know why that could be?
    [/EDIT]

    [EDIT2]
    Never mind the echo, I found the cause, apparantly I was directing the stdout to a file, I had forgotten I'd done that for debugging purposes
    [/EDIT2]
    Last edited by morfanaion; 08-05-2012 at 06:22 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •