Find the answer to your Linux question:
Results 1 to 5 of 5
I got SUSE 12.1 - 64bit to work flawlessly on an older laptop I got about 3 years ago, but it will not work on my new laptop I just ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2012
    Posts
    10

    Can't get SUSE 12.1 or 11.4 to work on my new laptop help


    I got SUSE 12.1 - 64bit to work flawlessly on an older laptop I got about 3 years ago, but it will not work on my new laptop I just bought. Also Ubuntu will work on my old laptop but it will not work on my new laptop as well. I tried installing SUSE 11.4 - 64bit on the new laptop as well since I read it was more stable then 12.1, but still same issues I am running into.

    SUSE will lock on the autoconfig install and only after restarting it over and over again does it sucessfully install. Once installed it is extremely buggy and often will freeze.

    I have tried using the options acpi= off apm=off nolapci and have tried booting into failsafe only for the OS to freeze on me after using it for 10 minutes. I also tried adding to the boot options b43.blacklist=yes and that did not work either.

    Any suggestions?

    Here are my laptop specifications:

    Toshiba - Satellite 15.6" laptop

    Toshiba laptop model C655D

    4GB memory

    320GB hard disk - SATA 5400 rpm
    HD Model: Toshiba MQ01ABD032 ATA Device

    Energy Star Qualified

    windows 7 home premium 64bit

    AMD E-Series Processor

    processor platform: VISION

    processor speed : AMD E-300 APU with Radeon(tm) HD Graphics 1.7 GHZ - Dual Core

    cache memory: 1MB

    Display: High definition TFT True Bright LED display 1366 x 768

    Graphics: AMD Radeon HD 6310 GPU

    optical drive: double-layer DVD+-RW/CD-RW

    Networking: Built in 10/100 Ethernet Lan; Wireless B+G+N

    wired adapter: Atheros AR8152/8158 PCI-E Fast Ethernet Controller (NDIS 6.20)

    wireless adapter: Realek RTL8188CE Wireless LAN 802.11n PCI-E NIC

    audio: Toshiba audio enhancement

    Mice & Touchpad: ELAN PS/2 Port Touch-Pad

    Printer: HP Deskjet 3520 series (NET)


    Any help would be greatly appreciated.
    Last edited by Gizmo007; 09-19-2012 at 06:00 PM.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,677
    There are a number of BIOS-related issues that can affect how Linux works on current generation machines. Is this using a traditional PC BIOS, or is it using a UEFI BIOS? If UEFI, then you need to get a UEFI-capable system and boot-loader.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Sep 2012
    Posts
    10
    Oh I was thinking it was a traditional BIOS, but your right it is an EFI one. I found a hidden EFI partion on my Hard Disk and a folder in my windows boot directory called EFI. It boots up fine ? It only locks up up once it gets in a GUI interface. It just seems to freeze in graphics mode when the operating system is trying to install on the hard disk.

    My guess is it is an issue with the ATI video card, I read online there were issues with the new ATI video cards not working with linux ... it is just my guess I am really not sure. The one time I did get linux installed on my new laptop the linux operating system reverted back to a very low quality graphic setting and I got a message that a compatible video driver could not be found, 10 minutes later the system froze. So I unistalled it and tried reinstalling it and haven't been able to get linux reinstalled on the laptop since. I wonder if linux is compatible with my laptop's dualcore cpu that has an intergrated Graphics Processing Unit? I wonder if there is anyway I could insert a compatible driver into Suse's 12.1 disk image file? I have inserted compatible drivers into windows disk images I have created for backups before, but I am not sure If I could do the same thing for linux? I have another laptop that I have had for 3 years that works fine with linux. I could always download drivers onto there and try to make a custom linux disk image off of that laptop, is that something I could do in linux?

    ... However if it is an issue with the UEFI BIOS where can I find a compatible boot loader at? Can I download one from SUSE?
    Last edited by Gizmo007; 09-25-2012 at 06:50 AM.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2012
    Location
    Finland
    Posts
    96
    You have to switch off UEFI in your laptop BIOS to load on any Linux distro's.

  6. #5
    Just Joined! dono725's Avatar
    Join Date
    Sep 2012
    Location
    NSW, Australia
    Posts
    28
    I am no expert but with my PC when I go to change the boot order I am given the option of two hard-drives and the CD-ROM drive. One is labeled UEFI. if this is the case just make sure that is the last option. I just drag the icons to make CD-ROM first (this for install only), then standard HDD second and UEFI last. hope this helps you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •