Find the answer to your Linux question:
Results 1 to 4 of 4
I recently upgraded from 11.4 to 12.1 and now I cannot logon to me desktop. It shows me the login screen and logs me in to an empty desktop with ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! ice2921's Avatar
    Join Date
    Feb 2008
    Posts
    6

    Cannot log on to desktop.


    I recently upgraded from 11.4 to 12.1 and now I cannot logon to me desktop. It shows me the login screen and logs me in to an empty desktop with just mouse functionality. I was getting an error that said that it was unable to load session "GNOME". So I though maybe it was because it my graphics card was too old and simply could not handle gnome 3, so I went into yast2 and removed all the packages that I could see that referenced gnome 3. It now get psat the error message but still drops me into a blank desktop with just the mouse. I am not sure what borked my system so any help would be much appreciated. Thank you all.

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Hi,

    Go to a virtual console (Ctrl+Alt+F1/F2/F3, etc.) and attempt to log in with your normal user account/password. If that works, then move your GNOME-specific dirs in your home directory to a backup location temporarily, e.g.

    Code:
    mv ~/.gnome ~/gnome-backup
    mv ~/.gnome2 ~/gnome2-backup
    you can also try blowing away /tmp files (as root).

    then jump back to your graphical login terminal (Ctrl+Alt+F7 or whatever) and try to log in.

  3. #3
    Just Joined! ice2921's Avatar
    Join Date
    Feb 2008
    Posts
    6
    Quote Originally Posted by atreyu View Post
    Hi,

    Go to a virtual console (Ctrl+Alt+F1/F2/F3, etc.) and attempt to log in with your normal user account/password. If that works, then move your GNOME-specific dirs in your home directory to a backup location temporarily, e.g.

    Code:
    mv ~/.gnome ~/gnome-backup
    mv ~/.gnome2 ~/gnome2-backup
    you can also try blowing away /tmp files (as root).

    then jump back to your graphical login terminal (Ctrl+Alt+F7 or whatever) and try to log in.
    Thanks for the response. I was able to move the gnome2 directory, but still logs on to blank desktop.

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    okay, you've got more options.

    first, check the contents of this file, if it exists:

    Code:
    ~/.xsession-errors
    if it has relevant info in it, post it here.

    if not, then continue reading.

    you can log in as root, and move your entire home directory, e.g.:

    Code:
    mv /home/$user /home/${user}.bak
    then recreate the dir, e.g.:
    Code:
    install -o $user -g $group -m 0700 -d /home/$user
    then try and log in.

    but before you do that, is gnome (or some other DE) installed? what is in this file?

    ~/.xsession

    also, can you reboot into text mode (i.e., runlevel 3 or whatever it is in your system) and get into graphical mode w/startx?

    if not, try putting the following into a file named ~/.xinitrc

    Code:
    #!/bin/bash
    exec gnome
    then make it executable, then run startx.

    if it doesn't work, check out the contents of your ~/.xsession-errors file, like before.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •