Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, I'm try to install ffmpeg from source to Suse Ent 11. I'm getting this error: Code: END /tmp/ffconf.e9UpPD2R.c gcc -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_POSIX_C_SOURCE=200112 -D_XOPEN_SOURCE=600 -std=c99 -fomit-frame-pointer -pthread -E -o ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2012
    Posts
    24

    Install FFMPEG


    Hi,

    I'm try to install ffmpeg from source to Suse Ent 11. I'm getting this error:
    Code:
    END /tmp/ffconf.e9UpPD2R.c
    gcc -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_POSIX_C_SOURCE=200112 -D_XOPEN_SOURCE=600 -std=c99 -fomit-frame-pointer -pthread -E -o /tmp/ffconf.gaxmXfeq.o /tmp/ffconf.e9UpPD2R.c
    /tmp/ffconf.e9UpPD2R.c:1:30: error: vorbis/vorbisenc.h: No such file or directory
    ERROR: libvorbis not found
    svr-apps1:~/ffmpeg # rpm -qa | grep libvorbis
    libvorbis-32bit-1.2.0-79.12
    libvorbis-1.2.0-79.12
    svr-apps1:~/ffmpeg #
    Any idea why? Seems suse ent no user friendly at all. Hope you guys can help me.

    Thanks.

  2. #2
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    I don't use SUSE, so my suggestions will be limited.
    I there a reason why you are compiling from source? It should be available in your package manager. Have you tried installing via Yast?
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  3. #3
    Just Joined!
    Join Date
    Nov 2012
    Posts
    24
    I'm try to install from source because the installation from Yast come out with error. I need enable some module in order to work my developer apps.
    The error is:
    http://postimage.org/image/felhjrb6l/
    Last edited by zabidin5417; 12-31-2012 at 05:00 AM. Reason: Add picture

  4. #4
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    You may be able to get around that by installing vlc-noX.
    Or,here is a link to download the needed libjack: libjack.so.0 RPM DEB Download
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  5. #5
    Linux User
    Join Date
    Dec 2011
    Location
    Turtle Island West
    Posts
    324
    I think you're missing the vorbis-devel- package that would have all the appropriate headers. devel packages are usually not installed by default.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •