Find the answer to your Linux question:
Results 1 to 4 of 4
Hello, I'm attempting to edit some files in an ISO file. I've mounted it and copied all the contents to a new folder. Edited the files I need to, and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2013
    Posts
    2

    Problem with lowercase/uppercase filenames when creating an ISO file


    Hello,

    I'm attempting to edit some files in an ISO file. I've mounted it and copied all the contents to a new folder. Edited the files I need to, and created a new one with this command:

    Code:
    mkisofs -iso-level 3 -o /root/Desktop/newisofile.iso /root/Desktop/DirectoryIAmCreatingTheISOFrom
    When this is done, I mount it:

    Code:
    mount -o loop newisofile.iso
    Now if I browse the iso file, all the directory names have become lowercase. I've tried to use the -U parameter, which should allow mixed case filenames, but with no effect.

    Btw I use the -iso-level 3, because if I don't, all files are restricted to 8 characters length.

    Any suggestions?

    Jacob.
    Last edited by atreyu; 05-17-2013 at 12:31 AM. Reason: added CODE tags to aid in readability

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    howdy Jacob, welcome to the boards!

    i think you need the Joliet option, e.g.:

    Code:
    mkisofs -J -o my.iso /dir

  3. #3
    Just Joined!
    Join Date
    May 2013
    Posts
    2
    Thank you very much, that did the trick!

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    sweet, glad you're sorted. i'll mark this as Solved. Note that you can mark your threads solved, too, using the Thread Tools link at the top of the page.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •