Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
Hi, I'm using openSUSE 12.3 (linux kernel 3.7ish) on a computer that doesn't have wireless capabilities, so I got a WLAN usb adapter. However, I can't figure out how to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2013
    Posts
    5

    Edimax Wireless USB Adapter Driver Installation


    Hi,
    I'm using openSUSE 12.3 (linux kernel 3.7ish) on a computer that doesn't have wireless capabilities, so I got a WLAN usb adapter. However, I can't figure out how to install the driver to get it working. I have read articles saying that linux kernel 3.x should support automatically, but it doesn't.
    The adapter came with an installation disk, but the auto-installation only works for windows and it didn't give instructions for linux. It has a driver in there as a .tar.gz file, but I don't know how to install that (i tried one method and it didn't work).
    Can someone give me advice? I've tried several things to no avail. one of them involved removing the default linux module using modprobe commands but it didn't even recognize modprobe. Someone please help and thanks in advance!

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    hello and welcome, JJossie!

    Go to this Wireless sticky first, and generate some system info, then post it back here.

    also, you may need to be root to run some commands, else you'll get the "command not found" error (re: your modprobe problems).

  3. #3
    Linux Newbie
    Join Date
    Jun 2004
    Location
    Halesowen, West Midlands, UK
    Posts
    107
    The type of adapter?
    "dmesg" should reveal what has been detected and if the firmware is present.
    "lsusb -vv" should also give details.

    I would be surprised if the openSUSE kernel does not support it.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    279
    I assume that is 'victor victor' (-v v, no space) and not w. Looks the same on my terminal, but it may be confused by others... Check the man pages...

    Jack

  6. #5
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by jkwilborn View Post
    I assume that is 'victor victor' (-v v, no space) and not w. Looks the same on my terminal, but it may be confused by others...
    you're right, Jack, that can be confusing. right along with the "-l" flag (is that a number One or a lower case L?). what i often do in these situations is copy and paste the text to a terminal or to a notepad, where I can see the mysterious text in a better font (like a monospace one, for example).

  7. #6
    Just Joined!
    Join Date
    Aug 2013
    Posts
    5
    Alright, I went to the Wireless sticky and here is the output. I also forgot to mention that the adapter itself is the Edimax EW-7811Un.

    Code:
    ============ lspci ============
    
    ============ lsusb ============
    Bus 001 Device 003: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
    Bus 003 Device 002: ID 413c:1005 Dell Computer Corp. Multimedia Pro Keyboard Hub
    Bus 005 Device 002: ID 058f:9360 Alcor Micro Corp. 8-in-1 Media Card Reader
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 003: ID 413c:2011 Dell Computer Corp. Multimedia Pro Keyboard
    Bus 003 Device 004: ID 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for Bluetooth
    
    ============ lsmod ============
    Module                  Size  Used by
    fuse                   80539  2 
    bnep                   18957  2 
    bluetooth             303438  7 bnep
    xt_tcpudp              12757  2 
    xt_pkttype             12457  3 
    xt_LOG                 17290  10 
    xt_limit               12542  10 
    ip6t_REJECT            12827  3 
    nf_conntrack_ipv6      14228  3 
    nf_defrag_ipv6         17873  1 nf_conntrack_ipv6
    ip6table_raw           12604  1 
    ipt_REJECT             12486  3 
    iptable_raw            12599  1 
    xt_CT                  12749  4 
    iptable_filter         12707  1 
    ip6table_mangle        12621  0 
    nf_conntrack_netbios_ns    12586  0 
    nf_conntrack_broadcast    12542  1 nf_conntrack_netbios_ns
    nf_conntrack_ipv4      14493  3 
    nf_defrag_ipv4         12650  1 nf_conntrack_ipv4
    ip_tables              17988  2 iptable_raw,iptable_filter
    xt_conntrack           12665  6 
    nf_conntrack           89684  6 nf_conntrack_ipv6,xt_CT,nf_conntrack_netbios_ns,nf_conntrack_broadcast,nf_conntrack_ipv4,xt_conntrack
    ip6table_filter        12712  1 
    ip6_tables             22066  3 ip6table_raw,ip6table_mangle,ip6table_filter
    x_tables               26164  15 xt_tcpudp,xt_pkttype,xt_LOG,xt_limit,ip6t_REJECT,ip6table_raw,ipt_REJECT,iptable_raw,xt_CT,iptable_filter,ip6table_mangle,ip_tables,xt_conntrack,ip6table_filter,ip6_tables
    snd_hda_codec_realtek    71841  1 
    snd_hda_intel          32794  3 
    snd_hda_codec         128773  2 snd_hda_codec_realtek,snd_hda_intel
    snd_hwdep              13273  1 snd_hda_codec
    snd_pcm                97659  2 snd_hda_intel,snd_hda_codec
    arc4                   12544  2 
    iTCO_wdt               13257  0 
    usb_storage            47841  0 
    iTCO_vendor_support    13503  1 iTCO_wdt
    snd_seq                63595  0 
    gpio_ich               13237  0 
    lpc_ich                16926  0 
    rtl8192cu             100712  0 
    rtl8192c_common        68744  1 rtl8192cu
    rtlwifi               103331  1 rtl8192cu
    mac80211              515125  3 rtl8192cu,rtl8192c_common,rtlwifi
    cfg80211              195534  2 rtlwifi,mac80211
    rfkill                 25445  3 bluetooth,cfg80211
    mperf                  12604  0 
    sr_mod                 21873  0 
    snd_timer              24319  2 snd_pcm,snd_seq
    joydev                 17098  0 
    sg                     35712  0 
    snd_seq_device         14138  1 snd_seq
    pcspkr                 12631  0 
    serio_raw              13160  0 
    snd                    70562  14 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_seq,snd_timer,snd_seq_device
    firewire_ohci          39618  0 
    firewire_core          61719  1 firewire_ohci
    crc_itu_t              12628  1 firewire_core
    cdrom                  41399  1 sr_mod
    i2c_i801               21997  0 
    microcode              22863  0 
    e100                   40000  0 
    soundcore              14600  1 snd
    snd_page_alloc         14231  2 snd_hda_intel,snd_pcm
    autofs4                33270  2 
    hid_generic            12485  0 
    usbhid                 51669  0 
    hid                    86116  2 hid_generic,usbhid
    ata_generic            12791  0 
    ata_piix               26399  3 
    rtc_cmos               18169  0 
    ahci                   25508  0 
    libahci                30205  1 ahci
    i915                  544952  3 
    drm_kms_helper         45273  1 i915
    uhci_hcd               35592  0 
    thermal                18248  0 
    drm                   243772  4 i915,drm_kms_helper
    i2c_algo_bit           13198  1 i915
    ehci_hcd               60431  0 
    processor              43569  1 
    button                 13665  1 i915
    i2c_core               34250  5 i2c_i801,i915,drm_kms_helper,drm,i2c_algo_bit
    libata                197443  4 ata_generic,ata_piix,ahci,libahci
    video                  18889  1 i915
    thermal_sys            24245  3 thermal,processor,video
    hwmon                  12912  1 thermal_sys
    usbcore               200347  6 usb_storage,rtl8192cu,rtlwifi,usbhid,uhci_hcd,ehci_hcd
    usb_common             12526  1 usbcore
    scsi_dh_emc            17062  0 
    scsi_dh_alua           16973  0 
    scsi_dh_rdac           17172  0 
    scsi_dh_hp_sw          12746  0 
    scsi_dh                14428  4 scsi_dh_emc,scsi_dh_alua,scsi_dh_rdac,scsi_dh_hp_sw
    
    ============ dmesg-firmware ============
    [   18.906180] rtl8192cu: Loading firmware rtlwifi/rtl8192cufw.bin
    
    ============ kernel version ============
    3.7.10-1.1-default
    
    ============ ifconfig ============
    
    ============ iwconfig ============

  8. #7
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    thanks for posting your output...however it looks like you did not run it as root. at least some of the commands are missing output. can you just run these commands - they are using absolute path name:

    Code:
    /sbin/lspci -v -v
    
    /sbin/ifconfig
    
    /sbin/iwconfig
    if they still don't work, try suing to root ("su -", then enter root's password), or if on *buntu, prepend "sudo " before each command (e.g., sudo /sbin/iwconfig)

  9. #8
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,903
    I don't run SuSE, but I do have this exact same network adaptor. Frankly I'm gobsmacked that it doesn't just work out of the box . On your system it's being detected by the USB framework, and you have the firmware available. Do you have NetworkManager working on your desktop? For me (admittedly, from Fedora) it allows all the local wireless networks to appear in the list, and I can just select a network to join in the usual way. This problem isn't caused because wireless networking is turned off in NetworkManager is it?

    If not, then keep following atreyu's advice, he knows what he's talking about with wireless networks.
    Linux user #126863 - see http://linuxcounter.net/

  10. #9
    Linux Newbie
    Join Date
    Jun 2004
    Location
    Halesowen, West Midlands, UK
    Posts
    107
    "ifconfig -a" should show wlan0.
    If wlan0 is up from the above command but not configured, you can use "YaST2 network" or NetworkManager to configure it which should generate
    /etc/sysconfig/network/ifcfg-wlan0

    In SUSE/openSUSE which have been using for decades, now on 13.1 Milestone 3.
    lsusb
    ---------
    Bus 006 Device 012: ID 0b05:1791 ASUSTek Computer, Inc. WL-167G v3 802.11n Adapter [Realtek RTL8188SU]

    I gave it the name 'RT73_Wireless' and I am using WPA-PSK authentication and the Passphrase is set to what the router expects.
    # cat /etc/sysconfig/network/ifcfg-wlan0
    BOOTPROTO='dhcp'
    BROADCAST=''
    ETHTOOL_OPTIONS=''
    IPADDR='0.0.0.0/32'
    MTU=''
    NAME='RT73_Wireless'
    NETMASK=''
    NETWORK=''
    REMOTE_IPADDR=''
    STARTMODE='hotplug'
    USERCONTROL='no'
    WIRELESS_AP=''
    WIRELESS_AP_SCANMODE='1'
    WIRELESS_AUTH_MODE='psk'
    WIRELESS_BITRATE='auto'
    WIRELESS_CA_CERT=''
    WIRELESS_CHANNEL=''
    WIRELESS_CLIENT_CERT=''
    WIRELESS_CLIENT_KEY=''
    WIRELESS_CLIENT_KEY_PASSWORD=''
    WIRELESS_DEFAULT_KEY='0'
    WIRELESS_EAP_AUTH=''
    WIRELESS_EAP_MODE=''
    WIRELESS_ESSID='TALKTALK-24C118'
    WIRELESS_FREQUENCY=''
    WIRELESS_KEY=''
    WIRELESS_KEY_0=''
    WIRELESS_KEY_1=''
    WIRELESS_KEY_2=''
    WIRELESS_KEY_3=''
    WIRELESS_KEY_LENGTH='128'
    WIRELESS_MODE='Managed'
    WIRELESS_NICK=''
    WIRELESS_NWID=''
    WIRELESS_PEAP_VERSION=''
    WIRELESS_POWER='yes'
    WIRELESS_WPA_ANONID=''
    WIRELESS_WPA_IDENTITY=''
    WIRELESS_WPA_PASSWORD=''
    WIRELESS_WPA_PSK='<WPA_Passphrase>'
    PREFIXLEN=''
    slipstream:/usr/src # cat /etc/SuSE-release
    openSUSE 13.1 Milestone 3 (x86_64)
    VERSION = 13.1
    CODENAME = Bottle

    slipstream:/usr/src # ifconfig wlan0
    wlan0 Link encap:Ethernet HWaddr 20:CF:30:C5:20:44
    inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::22cf:30ff:fec5:2044/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:81 errors:0 dropped:0 overruns:0 frame:0
    TX packets:381 errors:0 dropped:1 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:15050 (14.6 Kb) TX bytes:125317 (122.3 Kb)

  11. #10
    Linux User jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    279
    I agree, you are missing some of the usable output. The -v v (no space) can also have up to three v's for the most 'verbose'. You also seem to have a line or so missing from the dmesg output, like mine will say loading.. and the next line will say 'missing firmware' and/or give a filename for the file it's trying to load. I just grep the output from dmesg with whatever your identified item is. Like "dmesg | grep wifi" and that usually works. If you are new to Linux, then you may want to just pipe the output to a file and browse through it with an editor. Yes you can read the actual log file, but if you edit it you can save the pertinent parts.

    As was mentioned, you will probably need to be a super users because you don't want any user having access to your communications devices. It does appear that the firmware is loading, if the are not more messages from the device in dmesg. That is one nice thing about piping it to a file then just editing our what you want, because there is a lot you don't want. But looking through it I'm sure you'll see things you did not know.

    Did you load the package 'wireless-tools', I believe has the ifconfig and iwconfig software, which you can run with sudo. There is also a 'lsusb' which is in a different package called 'usbutils' that does a lot of lspci type stuff but for USB things.

    Keep us informed, and please don't close the thread without the solution. I've searched for many problems and found many where half the answer is there then the thread was closed with 'got it working' and that's it. Can be frustrating.

    Best of luck, you are on the right forums anyway!

    Jack

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •