Find the answer to your Linux question:
Results 1 to 3 of 3
Friends: OS: Open Suse 11.4 64 bit running inside Virtualbox. I am trying to make bash behave like cmd. It worked well in Arch Linux. Recently I felt like I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2013
    Posts
    2

    Question /etc/inputrc vs .inputrc and Open Suse 11.4 not cooperating.


    Friends:

    OS: Open Suse 11.4 64 bit running inside Virtualbox.

    I am trying to make bash behave like cmd.

    It worked well in Arch Linux.

    Recently I felt like I want to put this in Open Suse 11.4 and put the changes
    to .inputrc and restarted the box (permissions of .inputrc = 755)

    set completion-ignore-case on
    # Ignore case when doing completion
    set mark-directories on
    # Completed dir names have a slash appended
    set visible-stats on
    # List ls -F for completion
    "\C-i": menu-complete

    The TAB completion DID NOT work.

    Tried a lot but no luck.

    I then moved the above section to /etc/inputrc and restarted the machine and VIOLA the tab completion works.

    But in my office env, I dont have the luxury of modifying the /etc/inputrc and only .inputrc will help.


    Any ideas/suggestion would help.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,709
    Any ideas/suggestion would help.
    Stop trying to make Linux behave like Windows?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Aug 2013
    Posts
    2
    Hi Rubberman:

    I am not trying to make Linux behave like windows. I am trying to get some features of cmd.exe in bash to work.

    Infact it works in Arch Linux but we recently switched to OpenSuse and I am trying to make .inputrc work so tab completion works.

    Thanks for your suggestion.

    -N

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •