Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Hi I installed Suse on sdb and the first reboot showed an error message. on sda I have win7, so I guess that grub 2 was installed in the boot ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2013
    Posts
    7

    Installion on sdb


    Hi
    I installed Suse on sdb and the first reboot showed an error message.
    on sda I have win7, so I guess that grub 2 was installed in the boot partition of the first HD (sdb3). (although the boot flag was on the right partition-sdb2).
    Trying to find a solution, I messed up with grub and mbr so now only win7 starts.
    I have a laptop with BIOS and would like to use the one time boot menu for starting the OSīs.
    So now I have to reinstall grub2 in the right partition again (sdb2) and update mbr so that it will bring grub to start. I would like to use the Terminal, with a knoppix cd for doing it. But I dont know how to restor mbr (on sdb) or grub.
    Could someone help me with the right comands?
    Thanks

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    What was the error message?
    You don't need a boot flag set for Opensuse but I doubt that is part of the problem.
    If windows 7 starts, then you have its drive (sda) set to first boot priority. If you installed Opensuse Grub2 on the mbr of the sdb you need to set that drive to first boot priority in the BIOS.
    I would suggest you boot the Opensuse Live CD and go to the site below, read the instructions and download and run the bootinfoscript and post the output, a results.txt file here. That will give detailed information on drive/partitions and boot files which should help someone to help you:

    Boot Info Script | Free System Administration software downloads at SourceForge.net

  3. #3
    Just Joined!
    Join Date
    Aug 2013
    Posts
    7
    Thanks!! Somehow I canīt boot anymore from the live cd to the graphic layout, I always get into the black screen of Grub. So I hope itīs ok to run this bootinfoscreept from knoppix too.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2013
    Posts
    7
    Hi
    Here is the output of Boot Info Script:
    Code:
                      Boot Info Script 0.61      [1 April 2012]
    
    
    ============================= Boot Info Summary: ===============================
    
     => Syslinux MBR (4.04 and higher) is installed in the MBR of /dev/sda.
     => Syslinux MBR (4.04 and higher) is installed in the MBR of /dev/sdb.
    
    sda1: __________________________________________________________________________
    
        File system:       vfat
        Boot sector type:  Dell Utility: FAT16
        Boot sector info:  No errors found in the Boot Parameter Block.
        Operating System:  
        Boot files:        /DELLBIO.BIN /DELLRMK.BIN /COMMAND.COM
    
    sda2: __________________________________________________________________________
    
        File system:       ntfs
        Boot sector type:  Windows Vista/7: NTFS
        Boot sector info:  No errors found in the Boot Parameter Block.
        Operating System:  
        Boot files:        /bootmgr /Boot/BCD
    
    sda3: __________________________________________________________________________
    
        File system:       ntfs
        Boot sector type:  Windows Vista/7: NTFS
        Boot sector info:  No errors found in the Boot Parameter Block.
        Operating System:  Windows 7
        Boot files:        /bootmgr /Boot/BCD /Windows/System32/winload.exe
    
    sdb1: __________________________________________________________________________
    
        File system:       swap
        Boot sector type:  -
        Boot sector info: 
    
    sdb2: __________________________________________________________________________
    
        File system:       ext4
        Boot sector type:  Grub2 (v1.99)
        Boot sector info:  Grub2 (v1.99) is installed in the boot sector of sdb2 
                           and looks at sector 34011936 of the same hard drive 
                           for core.img. core.img is at this location and looks 
                           in partition 98 for .
        Operating System:  
        Boot files:        /grub2/grub.cfg
    
    sdb3: __________________________________________________________________________
    
        File system:       ext4
        Boot sector type:  -
        Boot sector info: 
        Operating System:  Welcome to openSUSE 12.3 
                           "Dartmouth" - Kernel ().
        Boot files:        /etc/fstab
    
    sdb4: __________________________________________________________________________
    
        File system:       ext4
        Boot sector type:  -
        Boot sector info: 
        Operating System:  
        Boot files:        
    
    ============================ Drive/Partition Info: =============================
    
    Drive: sda _____________________________________________________________________
    
    Disk /dev/sda: 320.1 GB, 320072933376 bytes
    255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Disk identifier: 0xf8000000
    
    Partition  Boot  Start Sector    End Sector  # of Sectors  Id System
    
    /dev/sda1                  63       417,689       417,627  12 Compaq diagnostics
    /dev/sda2             417,792    20,729,855    20,312,064  17 Hidden NTFS / HPFS
    /dev/sda3          20,729,856   623,933,439   603,203,584   7 NTFS / exFAT / HPFS
    
    
    Drive: sdb _____________________________________________________________________
    
    Disk /dev/sdb: 320.1 GB, 320072933376 bytes
    255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Disk identifier: 0x04f75401
    
    Partition  Boot  Start Sector    End Sector  # of Sectors  Id System
    
    /dev/sdb1               2,048    33,736,703    33,734,656  82 Linux swap / Solaris
    /dev/sdb2    *     33,736,704    35,839,999     2,103,296  83 Linux
    /dev/sdb3          35,840,000   316,866,559   281,026,560  83 Linux
    /dev/sdb4         316,866,560   625,141,759   308,275,200  83 Linux
    
    
    "blkid" output: ________________________________________________________________
    
    Device           UUID                                   TYPE       LABEL
    
    /dev/cloop0                                             iso9660    KNOPPIX_FS
    /dev/sda1        07DA-0717                              vfat       DellUtility
    /dev/sda2        64B866BCB8668BFC                       ntfs       RECOVERY
    /dev/sda3        2A6C56606C56273B                       ntfs       OS
    /dev/sdb1        19e256b9-0891-4cf7-b4c8-4a8eae7ec553   swap       
    /dev/sdb2        7b8ffeac-e28d-455a-afdd-dd0f36b933a2   ext4       
    /dev/sdb3        9286a48c-2ac6-46f0-b58f-293ec53145ed   ext4       
    /dev/sdb4        319fed7f-d28b-46c4-b709-4584c17c1417   ext4       
    
    ================================ Mount points: =================================
    
    Device           Mount_Point              Type       Options
    
    /dev/cloop       /KNOPPIX                 iso9660    (ro,relatime)
    /dev/sr0         /mnt-system              iso9660    (ro,relatime)
    
    
    ============================= sdb2/grub2/grub.cfg: =============================
    
    --------------------------------------------------------------------------------
    #
    # DO NOT EDIT THIS FILE
    #
    # It is automatically generated by grub2-mkconfig using templates
    # from /etc/grub.d and settings from /etc/default/grub
    #
    
    ### BEGIN /etc/grub.d/00_header ###
    if [ -s $prefix/grubenv ]; then
      load_env
    fi
    set default="${saved_entry}"
    
    if [ x"${feature_menuentry_id}" = xy ]; then
      menuentry_id_option="--id"
    else
      menuentry_id_option=""
    fi
    
    export menuentry_id_option
    
    if [ "${prev_saved_entry}" ]; then
      set saved_entry="${prev_saved_entry}"
      save_env saved_entry
      set prev_saved_entry=
      save_env prev_saved_entry
      set boot_once=true
    fi
    
    function savedefault {
      if [ -z "${boot_once}" ]; then
        saved_entry="${chosen}"
        save_env saved_entry
      fi
    }
    
    function load_video {
      if [ x$feature_all_video_module = xy ]; then
        insmod all_video
      else
        insmod efi_gop
        insmod efi_uga
        insmod ieee1275_fb
        insmod vbe
        insmod vga
        insmod video_bochs
        insmod video_cirrus
      fi
    }
    
    if [ x$feature_default_font_path = xy ] ; then
       font=unicode
    else
    insmod part_msdos
    insmod ext2
    set root='hd0,msdos3'
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd1,msdos3 --hint-efi=hd1,msdos3 --hint-baremetal=ahci1,msdos3 --hint='hd0,msdos3'  9286a48c-2ac6-46f0-b58f-293ec53145ed
    else
      search --no-floppy --fs-uuid --set=root 9286a48c-2ac6-46f0-b58f-293ec53145ed
    fi
        font="/usr/share/grub2/unicode.pf2"
    fi
    
    if loadfont $font ; then
      set gfxmode=auto
      load_video
      insmod gfxterm
      set locale_dir=$prefix/locale
      set lang=de_DE
      insmod gettext
    fi
    terminal_output gfxterm
    if [ x${boot_once} = xtrue ]; then
      set timeout=0
    elif sleep --interruptible 0 ; then
      set timeout=8
    fi
    ### END /etc/grub.d/00_header ###
    
    ### BEGIN /etc/grub.d/10_linux ###
    
    ### END /etc/grub.d/10_linux ###
    
    ### BEGIN /etc/grub.d/20_linux_xen ###
    ### END /etc/grub.d/20_linux_xen ###
    
    ### BEGIN /etc/grub.d/20_memtest86+ ###
    ### END /etc/grub.d/20_memtest86+ ###
    
    ### BEGIN /etc/grub.d/20_ppc_terminfo ###
    ### END /etc/grub.d/20_ppc_terminfo ###
    
    ### BEGIN /etc/grub.d/30_os-prober ###
    ### END /etc/grub.d/30_os-prober ###
    
    ### BEGIN /etc/grub.d/40_custom ###
    # This file provides an easy way to add custom menu entries.  Simply type the
    # menu entries you want to add after this comment.  Be careful not to change
    # the 'exec tail' line above.
    ### END /etc/grub.d/40_custom ###
    
    ### BEGIN /etc/grub.d/41_custom ###
    if [ -f  ${config_directory}/custom.cfg ]; then
      source ${config_directory}/custom.cfg
    elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
      source $prefix/custom.cfg;
    fi
    ### END /etc/grub.d/41_custom ###
    
    ### BEGIN /etc/grub.d/90_persistent ###
    ### END /etc/grub.d/90_persistent ###
    --------------------------------------------------------------------------------
    
    =================== sdb2: Location of files loaded by Grub: ====================
    
               GiB - GB             File                                 Fragment(s)
    
      16.231563568 = 17.428508672   grub2/grub.cfg                                 1
    
    =============================== sdb3/etc/fstab: ================================
    
    --------------------------------------------------------------------------------
    /dev/disk/by-id/ata-Hitachi_HTS725032A9A362_100611PCLC00VPK3MJAK-part1 swap                 swap       defaults              0 0
    /dev/disk/by-id/ata-Hitachi_HTS725032A9A362_100611PCLC00VPK3MJAK-part3 /                    ext4       acl,user_xattr        1 1
    /dev/disk/by-id/ata-Hitachi_HTS725032A9A362_100611PCLC00VPK3MJAK-part2 /boot                ext4       acl,user_xattr        1 2
    /dev/disk/by-id/ata-Hitachi_HTS725032A9A362_100611PCLC00VPK3MJAK-part4 /home                ext4       acl,user_xattr        1 2
    proc                 /proc                proc       defaults              0 0
    sysfs                /sys                 sysfs      noauto                0 0
    debugfs              /sys/kernel/debug    debugfs    noauto                0 0
    usbfs                /proc/bus/usb        usbfs      noauto                0 0
    devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
    --------------------------------------------------------------------------------
    
    =============================== StdErr Messages: ===============================
    
    mdadm: No arrays found in config file or automatically

  6. #5
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Your bootinfoscript does not show all the normal output it usually does. It does show that you do not have Grub installed to the master boot record of sdb, where Opensuse is installed. It shows Grub2 (v1.99) installed in the boot sector of sdb2, your boot partition so the files are there. If you install Grub to a partition, you need to install part of it to the master boot record or it will not boot and this appears to be what you have done. You need to install Grub to the mbr of /dev/sdb. I doubt that you will be able to do that with Knoppix, don't really know. I don't believe Knoppis will have Grub2 and you would be better off using the Opensuse disk as each distribution makes small modifications to the bootloader.

    You might try just googling 'reisntalling Grub2 to mbr on Opensuse' as each distribution is a little different. I haven't used Suse for over five years so doubt I'll be much help.

    I canīt boot anymore from the live cd to the graphic layout, I always get into the black screen of Grub. So I hope itīs ok to run this bootinfoscreept from knoppix too.
    Does that mean you can boot the Knoppix CD but not the Opensuse CD? That could be a problem. If this is a fresh install, you might be better off just reinstalling and make sure you get the drives correct. If Opensuse is going on sdb, install Grub2 to its mbr. Opensuse has a lot of confusing options in its bootloader install.

    Curious that you can boot Knoppix and not the Opensuse CD?

  7. #6
    Just Joined!
    Join Date
    Aug 2013
    Posts
    7
    Thanks for the help. I can boot OpenSuse CD but I donīt know how to reach the normal desktop screen of suse. There is an option to boot from hard disk, or to install, rescue, etc. but none of these options bring suse to boot up, or maybe Iḿ blind...?

    I know, a new install would be the fastest solution but Iḿ curious to know how to solve this problem...

    EDIT
    When I boot from Suse live cd I reach the minimal BASH-like black screen. on the top is writen: GNU GRUB Version 2.00.
    There is olso a comand line: grub>-
    Last edited by pudding; 08-28-2013 at 08:50 PM.

  8. #7
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Which version/release of Opensuse are you using? I've always used live cds and it gave the option to boot as a live medium which will take you to a normal Desktop which you would see if you installed. Maybe you just have an install CD, don't know if they have that option. Could you post a link to where you downloaded from or maybe the name of the iso file?

    The way to solve the problem is to install Grub to the mbr of sdb. I think a default install of Opensuse creates a / (root filesystem) partition, a boot and home partition. You selected to install Grub to the boot partition rather than the mbr as you can see in the bootinfoscript output. If you decide to reinstall, when you get to the Live Installation Settings window, you can click on any of the categories like 'Booting' and be taken to another page with a number of options. It can be pretty confusing.

    Anyhow, you should be able to reinstall Grub2 from the rescue option. Might try the Opensuse forums or googling that, make sure it is specific to Opensuse.

  9. #8
    Just Joined!
    Join Date
    Aug 2013
    Posts
    7
    Hi
    Im using the latest version of OpenSuse(12.3) which I downloaded from the oficial website ://software.opensuse.org/123/en.
    Two days ago I asked the same on the main OpenSuse forum and I worked on the problem nearly a whole night but I had the bad luck and their forum cruched down for nearly one day and all the threads of about 3 days disapeard, including mein, and I was so near to end...
    (maybe they had a virus attack? no information for users...)
    Through my experiments to solve the problem I formated by mistake the boot partition,.
    If you decide to reinstall, when you get to the Live Installation Settings window, you can click on any of the categories like 'Booting' and be taken to another page with a number of options. It can be pretty confusing.
    On monday I could still reach Suses normal desktop (with the "SuperGrub2" repair cd) and tried to install grub into the right partition (with YaST) but it didnt function, They also told me (in another forum) to mark the option: generic mbr.
    I guess the solution is very simple, maybe 10 minuets of action, but as a newbie it feels like I have to cross an ocean,..

  10. #9
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    You could try the suggestions at the link below if you can get to the rescue prompt as you previously indicated:

    https://forums.opensuse.org/content/...vd-rescue.html

  11. #10
    Just Joined!
    Join Date
    Aug 2013
    Posts
    7
    Thanks for the link!
    After typing this comand: grub2-mkconfig -o /boot/grub2/grub.cfg
    I got the errors opening path /mounts/instsys/sys/ block and faild to discover devices. Windows7(loader) found on sda and no volume groups found.
    I think I will reinstall the system.
    EDIT
    So now the system in reinstalled and functions (it starts from sba although I sett it to sdb but I can live with it..)
    Thanks for the help.
    Last edited by pudding; 08-29-2013 at 12:12 AM.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •