Find the answer to your Linux question:
Results 1 to 6 of 6
Well, I haven't been here for a while but maybe it's time now. The problem has occurred at more places I've already read, so maybe a bug. On one machine ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Mar 2007
    Posts
    142

    Problem?


    Well, I haven't been here for a while but maybe it's time now.
    The problem has occurred at more places I've already read, so maybe a bug.

    On one machine was installed opensuse 11.1 with dual boot windows and that did fine.
    First harddisk is ide-pata and called /dev/sda
    Second harddisk is sata and called /dev/sdb
    Third harddisk is sata and called /dev/sdc

    I did an upgrade via the opensuse 11.4 DVD but the installer said the opensuse partition is on /dev/sdc.
    So I uncoupled the two sata drives and did the install on /dev/sda as it should be.
    The upgrade (on the dvd they call it update) went fine just as the online update afterwards.
    Then I recoupled de sata drives and restarted and everything was still ok.
    But the fdisk -l was not ok, saying:
    First disk became /dev/sdc
    Second disk became /dev/sda
    Third disk became /dev/sdb
    I have tried everything in fstab and partitioning by id, uuid, path etc but to no avail.
    The odd thing is that it boots via grub as hd 0 and if sdc should be correct it should be hd 2.

    If I boot on the parted magic cd it also said:
    First disk /dev/sda
    Second disk /dev/sdb
    Third disk /dev/sdc

    So what's the solution on this problem?
    And what causes these things?
    Can with opensuse 11.4 only sata drives being the first?

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,709
    The problem is that the order of initializing the drives is not guaranteed, especially between OS upgrades. Please post the contents of /etc/fstab on what was your old /dev/sda drive (which I assume was the boot drive). Some systems will use the device designators (/dev/sda, etc), some will use GUIDs, and you can optionally name your file systems and specify the names in /etc/fstab (my preferred method). In any case, the first method is prone to problems, especially if you change/update the OS or add/remove a drive. The GUID or name methods will over-ride that situation. Here is an example of my /etc/fstab:
    Code:
    LABEL=/                 /                       ext4    defaults        1 1
    LABEL=swap1             swap                    swap    defaults        0 0
    tmpfs                   /dev/shm                tmpfs   defaults        0 0
    devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
    sysfs                   /sys                    sysfs   defaults        0 0
    proc                    /proc                   proc    defaults        0 0
    LABEL=afs-ts02          /mnt/ts02               ext4    defaults        1 2
    LABEL=afs-esata-1       /mnt/esata1             ext4    defaults        1 2
    LABEL=afs-esata-2       /mnt/esata2             ext4    defaults        1 2
    LABEL=afs-esata-3       /mnt/esata3             ext4    defaults        1 2
    LABEL=afs-esata-4       /mnt/esata4             ext4    defaults        1 2
    What that buys me is the ability to swap out drives and not affect the operation of the system.

    All that said, since everything is working, I suspect that OpenSUSE has properly used GUIDs or LABELs for your file systems, including / which is why the system is still ok. It may also be that 10.4 deliberately scans for sata drives before pata ones since they are better performing, which would also explain this behavior.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Linux Newbie
    Join Date
    Mar 2007
    Posts
    142
    It's so that I have already used suse 9 and suse 10 and always did edit fstab and grub and kept an eye on files and things.
    But I have read that opensuse 11.2 and 11.3 did run fine with no problems but with 11.4 the swapping of drives stuff began (ide-sata).
    With the possible associated boot problems.
    But if one uses only sata drives the problem should not exist.

    The boot drive is the first drive is de ide-drive.
    /dev/sda1 windows
    /dev/sda3 linux
    /dev/sda4 swap
    /dev/sda5 windows
    Windows boots in grub with (hd0,0) with chainloader and opensuse in (hd0,2) both in 11.1 and now in 11.4.
    But fdisk -l gives the above list with sdc instead of sda.

    I have already changed the disk by-id in all others before upgrading to 11.4.
    And now again I have tried all, but to no avail so the fstab has changed accordingly.
    At the moment in the fstab I have the disk by-path method and it is:
    /dev/disk/by-path/pci-0000:00:06.0-scsi-0:0:0:0-part3 / ext3 acl,user_xattr 1 1
    /dev/disk/by-path/pci-0000:00:06.0-scsi-0:0:0:0-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.U TF-8 0 0
    /dev/disk/by-path/pci-0000:00:06.0-scsi-0:0:0:0-part5 /windows/D ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.U TF-8 0 0

    If I change to the disk by-uuid then the line begins with UUID=....... a long number which is also correct.
    If I change to the disk by-id then the line changes to /dev/disk/by-id/ata-ST3250820A......... part3 / etc
    So the disk id and uuid are all correct.
    Even so the other sata drives.

    The only wrong thing is that opensuse swaps all drives to another sdx.
    I have looked at the kernel ata modules which are loaded with the kernel and they are: pata_amd and ata_generic.
    Plus the rest of the stuff of course.

    There must be some way to correct these things because with opensuse 11.1, 11.2 and 11.3 there seemed to be no problems.
    Thank you for your interest.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,709
    You could create a modified kernel that loads the pata drive before the sata drives, but then you'd need to update every time the kernel changes.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  6. #5
    Linux Newbie
    Join Date
    Mar 2007
    Posts
    142
    Maybe, but how to do that?
    I cannot imagine that was the intention of opensuse 11.4

    If the pata driver has to load first why should the kernel be changed?

    Strange because this must have happened many more times with more users.

  7. #6
    Linux Newbie
    Join Date
    Mar 2007
    Posts
    142
    I don't get it!
    I've Tried to change the pata drivers but after reboot it still were the same which are loaded.
    I even blackmailed one but again after reboot he was still there.
    So I don't understand what's going on there.

    I always thougt that linux was precise and secure.
    But this way one can't change anything.

    But still waiting if someone somewhere has experienced this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •