Find the answer to your Linux question:
Results 1 to 3 of 3
hi. i use opensuse 12.3. and this is fstab: Code: /dev/disk/by-id/ata-MAXTOR_STM3250310AS_6RY6W8ZM-part1 swap swap defaults 0 0 /dev/disk/by-id/ata-MAXTOR_STM3250310AS_6RY6W8ZM-part2 / ext4 acl,user_xattr 1 1 /dev/disk/by-id/ata-MAXTOR_STM3250310AS_6RY6W8ZM-part3 /home ext4 acl,user_xattr 1 2 proc /proc ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2013
    Posts
    5

    opensuse 12.3 cannot read and write to ext4


    hi.
    i use opensuse 12.3.
    and this is fstab:

    Code:
    /dev/disk/by-id/ata-MAXTOR_STM3250310AS_6RY6W8ZM-part1 swap                 swap       defaults              0 0
    /dev/disk/by-id/ata-MAXTOR_STM3250310AS_6RY6W8ZM-part2 /                    ext4       acl,user_xattr        1 1
    /dev/disk/by-id/ata-MAXTOR_STM3250310AS_6RY6W8ZM-part3 /home                ext4       acl,user_xattr        1 2
    proc                 /proc                proc       defaults              0 0
    sysfs                /sys                 sysfs      noauto                0 0
    debugfs              /sys/kernel/debug    debugfs    noauto                0 0
    usbfs                /proc/bus/usb        usbfs      noauto                0 0
    devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
    /dev/disk/by-id/ata-WDC_WD10EARS-14Y5B1_WD-WCAV5S728476-part1 /media/Archive      ext4 acl,user_xattr 1 2
    but i can not read or write to /media/Archive , ext4 hdd.
    in root , i can do any things , but in normaly user i cant.
    please help.

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Check the owner:group and permissions with the command: ls -ld /media/Archive
    If it is root:root then you can change the owner, or you can change the group and put whichever user you want into that group with write permissions.

  3. #3
    Just Joined!
    Join Date
    Oct 2013
    Posts
    5
    Quote Originally Posted by yancek View Post
    Check the owner:group and permissions with the command: ls -ld /media/Archive
    If it is root:root then you can change the owner, or you can change the group and put whichever user you want into that group with write permissions.
    its root:root.

    i try to change it but when i enable "Apply changes to all subfolders and their contetns" its still in Apply changes and nothing to do.

    i try to change my default group to root but no change.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •