Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    France + UK

    Where do I change the screen resolution when using vnc?

    (this on Suse 13.1 using tigervnc 1.3.0)
    I connect to the VNC server, first by typing in the vnc password that I have set up. That opens up the "greeter" screen with the resolution set in the Xinetd.d/vnc configuration file. There I see my normal login screen with my name visible. I type in my normal user linux password and KDE launches. However, as KDE is in the process of launching, something changes the screen resolution to something much bigger, too big in fact to fit on the KRDC vnc client screen (although KRDC does conveniently give scroll bars so it is sort-of possible to use it).
    My question is really two fold:
    1. An immediate solution to the question "which configuration file determines that KDE changes the X window resolution" so I can fix it.
    2. (much better) can someone explain the sequence of start-up to me please. I have deduced that Xinitd listens on port 5901 for a connection, then launches Xvnc with the arguments given in xinitd.d/vnc - this includes the correct X and Y screen resolution. I cannot find any description of what happens after that. Does Xvnc invoke "startx" or what? Explanation of the KDE startup operations would be gratefully received.

    I suspect that the screen resolution used is determined by the physical screen that I use when I log in locally - but I don't really know

  2. #2
    Just Joined! bcbuch's Avatar
    Join Date
    Nov 2013
    Higden, Arkansas

  3. #3
    Just Joined!
    Join Date
    Jun 2005
    France + UK

    Yup, have been reading that, it doesn't work as described.

    Quote Originally Posted by bcbuch View Post
    Chapter*5.*Remote Access with VNC

    Have a read.
    Thank you for responding. I am sorry that you had difficulty following my question; this timel I will try to be more explicit and clear.
    I was following as precisely as I could the instructions in the document you cited. (yes I RTFM) . I had already edited /etc/xinetd.d/vnc to fix an authentication problem so I am aware how to configure one time vnc sessions. Yes, I am connecting to port 5901. I know that because the rfbauth entry works in the Xvnc server arguments which I copy for your interest below:

    service vnc1
            socket_type     = stream
            protocol        = tcp
            wait            = no
            user            = sanktwo
            group           = users
            server          = /usr/bin/Xvnc
            server_args     = -noreset -inetd -once -query localhost -geometry 1024x768 -depth 16 -rfbauth /home/sanktwo/.vnc/passwd
            type            = UNLISTED
            port            = 5901
    As I pointed out ion the original post, Xvnc obeys those arguments and indeed opens up a remote X terminal of 1024x768 determined by line 9 above and presents the normal login screen. As far as I can determine there is no other method of configuring Xvnc itself apart from through the arguments; certainly none mentioned in the reference you cited. No, I do not want a permanent terminal using vncserver though I have done some testing with that.

    If I don't log in there is no further problem. i.e. the login screen stays cosily sitting in the middle of my KDRC window. Problems start when I log in. The first step is that the normal kde background opens up, and, as is usual, icons begin to fade into a panel in the middle of the screen (still a cosy 1024x768 ). The icon resembling a disc appears first with no change to the screen dimensions. Then disaster! as the second item appears (looks like a toolbox) odd things begin to happen to the screen. Scroll bars appear right and bottom, a big black area appears to the right, things jump about etc. etc. Eventually it settles to a very large screen with the program launcher invisible off the bottom. Now, I fully understand I have three options in this case:
    1. I can scroll back and forth all the time around the screen (about one third of the screen is invisible at any time)
    2. I can scale the screen in KRDC
    3. I can try to fix the problem of it disobeying my configuration.

    Whilst the first two of these options avoid the need to fix the problem, each has their own tedium. In the first case, much scrolling and in the second jolly difficult for an old fart like me to read.

    That being the case, I thought I would seek the expertise available on on option 3 having exhausted my ability to find out by googling. I did start looking at the source code of Xvnc but then I realised that it is probably nothing whatsoever to do with xinetd or Xvnc and probably something to do with the behaviour of KDE i.e. for some reason kde decides it doesn't like the 1024x768 X terminal it has been given by Xvnc and demands something else of the X server built into Xvnc.
    So my original quesion perhaps should have been: what other configuration overrides my configuration in /etc/xinetd.d/vnc ?

    Thanks for everyones attention....
    Last edited by sanktwo; 01-26-2014 at 03:15 PM.

  4. $spacer_open
  5. #4
    Just Joined!
    Join Date
    Jun 2005
    France + UK

    Red face Found it!

    Sorry to trouble you, but I eventually found the way of doing it. It is KDE and it is easy to fix in the KDE Gui once you are logged in, I just couldn't see it before.

    It is in "system settings", "display and monitor" and is a little icon on the pseudo screen of "vnc0". Once I figured out is was actually a clickable icon, choices open up for the screen resolution.

    Sigh. Sorry to trouble everybody for something so trivial.

    Just to note though that the configuration as described in the Xvnc manuals ONLY applies to the login screen in the case of kde users.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts