Find the answer to your Linux question:
Results 1 to 4 of 4
Hello! I got headache with sound stuff in SuSE 11 SP3 using Audio device (Intel Corporation Haswell HD Audio Controller). The driver is "snd-hda-intel" as result in "lspci -vvv". I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2014
    Posts
    3

    Unhappy No audio in Intel Haswell audio controller


    Hello! I got headache with sound stuff in SuSE 11 SP3 using Audio device (Intel Corporation Haswell HD Audio Controller). The driver is "snd-hda-intel" as result in "lspci -vvv". I added a "model=generic" in the options but it returns "No elems found" in alsamixer. I tried also "model=auto" luckily it will open now the alsamixer but you can't adjust the mixer it will always be in zero value. Still no luck using "aplay" it always return an error result "ALSA lib pcm_dmix.c:1008snd_pcm_dmix_open) unable to open slave. aplay: main:590a; audio open error: No such file or directory" Anyone there knows the options for Haswell audio driver? Let me know if you need further details on my question. Thanks in advance. 

  2. #2
    Just Joined!
    Join Date
    Apr 2014
    Posts
    3
    Uppppppppppppppppppppppp.... please help me please.. need your ideas..

  3. #3
    Linux Newbie
    Join Date
    Nov 2009
    Posts
    218
    Any particular reason you are using a release that is way way out of date and is now unsupported?

    Also. What do you mean SP3?

    Go into yast and try to configure the sound card. Be sure to test it. Is the module snd_pcm_oss loaded? If not, load it at boot time by adding it to the list of modules to be loaded in the file at /etc/sysconfig/kernel.

    Oh. Make sure that the device is not muted. Fire up a mixer (kmix or whatever) and check out the channel levels.

    There are some tools that shipped with alsa back in the day that can sometimes give good clues.

  4. #4
    Just Joined!
    Join Date
    Apr 2014
    Posts
    3
    Thats what we support now. SUSE Linux Enterprise 11 Service Pack 3. I'll try your suggestion voidpointer69. Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •