Find the answer to your Linux question:
Results 1 to 7 of 7
I've installed and set up a whole slew of distros, but I'm now trying openSUSE for the first time. In short, I'm completely ignorant of openSUSE and the KDE desktop. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! YourPalMark's Avatar
    Join Date
    Oct 2013
    Location
    Fort Worth, TX
    Posts
    48

    Require Password at Login, openSUSE 13.1


    I've installed and set up a whole slew of distros, but I'm now trying openSUSE for the first time. In short, I'm completely ignorant of openSUSE and the KDE desktop. Don't ask me why I did this, but during the install I kept the box checked that allows for auto login, and I'm now trying to figure out how to change things so that when the system boots I'll be prompted for my password. Can someone point me in the right direction? Thanks!

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    I don't use Opensuse but with KDE, you usually have an option to configure your Desktop. In the System Administration is an option for Login Screen. If you open that, you should get a new window with a number of tabes. The one on the far right is 'Convenience'. Click that tab and there should be a box to Enable Password-Less Logins. Uncheck the box and uncheck the user in the window below. If you don't have these options with KDE, I don't have any other ideas.

  3. #3
    Just Joined! YourPalMark's Avatar
    Join Date
    Oct 2013
    Location
    Fort Worth, TX
    Posts
    48
    Quote Originally Posted by yancek View Post
    I don't use Opensuse but with KDE, you usually have an option to configure your Desktop. In the System Administration is an option for Login Screen. If you open that, you should get a new window with a number of tabes. The one on the far right is 'Convenience'. Click that tab and there should be a box to Enable Password-Less Logins. Uncheck the box and uncheck the user in the window below. If you don't have these options with KDE, I don't have any other ideas.
    Thanks yancek, I read something similar to what you suggest on another site, and when I go to "Convenience" I find that the boxes that would disable the password login are already unchecked. Maybe I should just break down and re-install.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    I guess the Auto-Login option is unchecked also, it's on the same Convenience tab. I have no idea what else you could try.

  6. #5
    Linux Guru
    Join Date
    Dec 2013
    Location
    Victoria, B.C. Canada
    Posts
    1,659
    Take a look at /etc/sysconfig/displaymanager. I think you'l find DISPLAYMANAGER_AUTOLOGIN set to your user name. Set it to "". DISPLAYMANAGER_PASSWORD_LESS_LOGIN might also be in there and should be set t no.

  7. #6
    Just Joined! YourPalMark's Avatar
    Join Date
    Oct 2013
    Location
    Fort Worth, TX
    Posts
    48
    Quote Originally Posted by gregm View Post
    Take a look at /etc/sysconfig/displaymanager. I think you'l find DISPLAYMANAGER_AUTOLOGIN set to your user name. Set it to "". DISPLAYMANAGER_PASSWORD_LESS_LOGIN might also be in there and should be set t no.
    Thanks, I'll give it a try!

  8. #7
    Just Joined!
    Join Date
    Oct 2014
    Posts
    1
    I've had the same problem. But I've found the answer. OpenSuse13.1 with KDE4 is very complicated. To stop auto Login Open YAST & go to section "Security and Users". In that section Open User and Group Management click on your user name, the click on expert options & click on login options & uncheck {Auto Login}.
    Note that this configuration page is not in the KDE configuration Page, but in YAST. I imagine that you also have to check any relevant setting in the KDE settings.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •