Find the answer to your Linux question:
Results 1 to 3 of 3
I've recently installed SuSE Enterprise Server 8 on a PC for my wife (just a desktop install). I've been trying to configure it so that she can print on the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Location
    Ellicott City, MD
    Posts
    17

    trouble installing hp inkjet driver


    I've recently installed SuSE Enterprise Server 8 on a PC for my wife (just a desktop install). I've been trying to configure it so that she can print on the hp psc1315 inkjet printer that is connected to my Red Hat Linux PC. The SuSE installation does not appear to include the necessary driver, so I went to the hp driver project at sourceforge and followed their intructions for downloading and building the driver: http://hpinkjet.sourceforge.net/install.php (I had earlier done this for my Red Hat machine.)

    The instructions identify six packages that I needed to ensure were installed. When I searched for these in YAST, it found and installed cups-devel, python-devel, and openssl. When I searched for python-xml, PyQt, and net-snmp-devel, however, YAST didn't respond - no messages or anything. I don't know what this means, exactly, but I assume at a minimum the packages aren't there.

    I tried to run the configure script that came with the tar.gz file I downloaded from sourceforge, and it complained about missing compilers and such until I installed gcc, gcc++, and some related libraries. Then it seemed to run okay.

    When I ran make, it didn't report any errors that seemed obvious to me. I dumped the output to a text file, which I can post here, although it's 600+ lines, so I don't want to do that unless someone asks.

    Everything appeared to be okay, but the instructions next told me to restart the /ect/init.d/hplip daemon, and that failed for something called hpssd.
    (It fails for both the stop or the start command.)

    I don't even know what that daemon is, so I'm at a loss. Does anyone have any suggestions?

    thanks a lot,
    Bruce[/b]

  2. #2
    Just Joined!
    Join Date
    Jan 2005
    Posts
    8
    hi,
    i'm running suse 9.2 on my laptop and i came across same problem trying to set up my psc1315. although printing worked fine - scaner did nothing. so i underwent same steps as you and got identical messages: no pyqt or net-snmp-devel on yast....i had help from couple of my linux/powerusers friends, but all for nothing...couldn't get scaner work...
    but if you are looking just for a printing - well, suse 9.2 pro has ready-to-go drivers preinstalled...just upgraid to 9.2 and you are set...

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Location
    Ellicott City, MD
    Posts
    17
    It's good to hear that SuSE 9.2 has the necessary driver - now I just need to learn how to upgrade my distro. I haven't yet figured out the difference between SuSE Enterprise Server 8, which is what I've installed (just the desktop portion) and SuSE 9.2, so maybe I'll start there.

    I haven't gone searching for those missing packages yet, but it's on my list to do.

    As for the scanner, I got it working pretty easily on my Red Hat machine, but that probably isn't much help to you. As I recall, you need to have SANE properly installed, and then there's an hp-specific "backend" for SANE that lets it receive data from the hp scanner.

    If you think it would help to know how things are configured on my Red Hat machine, let me know. I'd be happy to answer anything I can.

    - Bruce
    Quote Originally Posted by ZarbaZana
    hi,
    i'm running suse 9.2 on my laptop and i came across same problem trying to set up my psc1315. although printing worked fine - scaner did nothing. so i underwent same steps as you and got identical messages: no pyqt or net-snmp-devel on yast....i had help from couple of my linux/powerusers friends, but all for nothing...couldn't get scaner work...
    but if you are looking just for a printing - well, suse 9.2 pro has ready-to-go drivers preinstalled...just upgraid to 9.2 and you are set...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •