Find the answer to your Linux question:
Results 1 to 5 of 5
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    'Pipe' key has no output


    Hi,

    I'm running Suselinux LEAP 42.1 on a Dell Optiplex 780 with a Windows keyboard by Acer.

    The key, on the left side of the board, which has the backslash and the pipe symbol on it, gives no output.

    I have run showkey and nothing happens for that key.

    I have run

    Code:
    xmodmap -pke
    but can find no reference to either 'pipe' or 'vertical bar' however, there are many keys which have the XF86WebCam entry or are blank ie

    Code:
    keycode 219 =
    keycode 220 = XF86WebCam NoSymbol XF86WebCam
    keycode 221 =
    keycode 222 =
    I thought the keycode for the pipe symbol was 220 but can't find where I discovered that!

    Would somebody look at their xmodmap and find the entry for the pipe symbol so that I can add it to my map.

    Thanks

    Chris

  2. #2
    Linux Guru Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    1,687
    xev tells me keycode 51.

  3. #3
    Thanks Segfault.

    Could you show me the line for that keycode as reported by

    Code:
     xmodmap -pke
    I have read that creating .Xmodmap will cause any alterations I introduce to be read and used when starting an X11 environment but is there a more permanent way to add this pipe symbol to my set up?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    1,687
    Code:
    keycode  51 = backslash bar backslash bar
    Good luck with ~/.Xmodmap, modern login managers and desktop environments may not read it, ignoring good old conventions.

  6. #5
    Thanks for that.

    Yes, I take your point about *modern login managers.

    I have now found that with Alt/grey, the 'broken pipe' symbol does the same job so perhaps I'll not pursue this further.

    Thanks for your help.

    One last question, how do I mark this thread 'Closed'?

    Or do you do that?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •