Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 22
In the /etc/fstab file, there is a line which contains the word swap (twice). If you comment out this line, your machine will no longer use the swap partition at ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204

    In the /etc/fstab file, there is a line which contains the word swap (twice). If you comment out this line, your machine will no longer use the swap partition at boot (the swap partition is a lot like the Windows pagefile, using hard drive space in the same way as RAM).

    If your /etc/fstab file looked like this:
    IW /etc/fstab (Read only) Row 1 Col 1 2:02 Ctrl-K H for help
    /dev/sda3 / reiserfs acl,user_xattr 1 1
    /dev/sdb1 /Firewire vfat defaults 0 0
    /dev/sda1 /WindowsXP ntfs defaults 0 0
    /dev/hda2 /storage reiserfs defaults 1 2
    /dev/sda2 swap swap pri=42 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    proc /proc proc defaults 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    sysfs /sys sysfs noauto 0 0
    /dev/cdrecorder /media/cdrecorder subfs fs=cdfss,ro,procuid,nosuid
    /dev/dvdrecorder /media/dvdrecorder subfs fs=cdfss,ro,procuid,nosuid
    /dev/fd0 /media/floppy subfs fs=floppyfss,procuid,nodev

    You would change it to this:
    IW /etc/fstab (Read only) Row 1 Col 1 2:02 Ctrl-K H for help
    /dev/sda3 / reiserfs acl,user_xattr 1 1
    /dev/sdb1 /Firewire vfat defaults 0 0
    /dev/sda1 /WindowsXP ntfs defaults 0 0
    /dev/hda2 /storage reiserfs defaults 1 2
    #/dev/sda2 swap swap pri=42 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    proc /proc proc defaults 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    sysfs /sys sysfs noauto 0 0
    /dev/cdrecorder /media/cdrecorder subfs fs=cdfss,ro,procuid,nosuid
    /dev/dvdrecorder /media/dvdrecorder subfs fs=cdfss,ro,procuid,nosuid
    /dev/fd0 /media/floppy subfs fs=floppyfss,procuid,nodev

    Note the # before /dev/sda2; it is used to "comment out" the line so that the machine won't use it.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  2. #12
    Just Joined!
    Join Date
    Mar 2005
    Posts
    16

    How do I edit fstab tile?

    I feel so stupid but I do understand what you are saying about entering the # sign at the beginning of a line, I have done that often in Windows, BUT when I try to edit the file it won't let me saying I don't have permissions! grrhhhh

    How do I get around this? pretty please

  3. #13
    Linux Engineer
    Join Date
    Mar 2005
    Location
    Where my hat is
    Posts
    766
    Open a console and login as root..

    Code:
    su root
    password
    Then edit the file.
    Registered Linux user #384279
    Vector Linux SOHO 7

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    577
    Suse is slow on old machines

  6. #15
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    You have to be root to edit that file. Type su and enter your root password (in a terminal) and you should be able to edit the file.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  7. #16
    Just Joined! petergriffin's Avatar
    Join Date
    Nov 2004
    Location
    East Midlands, UK
    Posts
    93
    Can't give you any technical help..but for what it's worth, I have had SuSE 9.1 on a 7 year old Dell laptop which was Pentium 2 and it ran no problem! The only one I have noticed it to be a teeny bit slower is on a pc with 128MB memory...

  8. #17
    Just Joined!
    Join Date
    Mar 2005
    Posts
    16

    Am I sooooo stupid?

    I feel so stupid but I have tried everything to edit this blasted fstab file and have failed.

    I have gone to Konsole, typed in su and then my password opened a midnight commander session, which I think is great as it reminds me so much of DOS and XTree (am I showing my age?), found the file and opened it edited it and tried to save it but it won't let me!!!!!!!!!!!1

    I am getting so fed up of the password thingie, can I turn if off as I am the only user?

  9. #18
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Actually that "password thingie" is one of the things that makes linux much more secure than Windows. Bad things you encounter on the net can't get to your hard drive because they don't have your root pasword.

    But, if you surf the net as root, they don't need the password to get in.

    How are you trying to save the file.
    If you use vi(my favorite text editor) type vi /etc/fstab
    then " i " type whatever you need, hit ESC, and type "ZZ" to save your work.

    Hope this helps.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  10. #19
    Just Joined!
    Join Date
    Dec 2004
    Location
    Omaha NE (USA)
    Posts
    51
    AnswerLady:

    Many long-time Linux users give you instructions on how to do this or that using the Konsole (or Terminal window). Another way to edit files is via the Konqueror file manager. There are usually two icons (or for sure, two menu items) for Konqueror. The one that is labled "My Computer" - is run as User. That means you can only "change" files in your Home directory. Since etcee (/etc) is not in your home directory, you need to open the version of Konqueror that has a label like "file manager super user". When you open Konqueror (file manager super user) - you'll be prompted for your password. Once you do that, you'll have read & write for all directories including /etc. You may have to play around with Konqueror for a little while, it's just different enough from IE file manager. Click on the various icons. You should be able to set it up to have a navigator pane and a file colume to the right. Find the file suggested, and right click to get a window that allows you to open with the editor of your choice. I would suggest something like Kword or Kate. (you may want to make a copy of the original file first). Then add the comment # symbol to have the OS ignore that line. BTW, I run Suse on 3 PC's, one is 6 or 7 years old, and has 192 meg of ram and a 566 mghz celeron. I think the key is to have more than 128 ram, and at least 550 mghz processor speed. Suse runs just fine on that. Compatible speedwise with Win98 - but 100 times more reliably. IF you're serious about learning Linux - there are many online sources of info and tutuorials. Look up the "Rute" guide. Also, a newer book that is outstanding for ex windows Power Users in "How Linux Works" - or running Linux for "Superusers" - it covers ALL the important stuff like file systems, installing programs, and so on. Hope this helps. Besides this very good forum, take a look at http://www.suseforums.net/ AND http://slforums.typo3-factory.net/index.php?act=idx

  11. #20
    Just Joined!
    Join Date
    Mar 2005
    Posts
    16

    Yeeeeeeeeeeeeeeessssssssssssssss

    Oh thank you, gottit!

    I am right chuffed and grateful for your patience and help,

    I will also be getting more into Linux as I will be setting up my wirelss network from tomorrow, I have been on dialup for a month or so whilst changing broadband ISP and will be back on broadband from tomorrow, 12th, yippee :P

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •