Find the answer to your Linux question:
Results 1 to 9 of 9
SuSE 9.1 x86 riva TNT 2 64 well i will start all over again im trying to make my nvidia work for my SuSE for about 2 months now =) ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    8

    nvidia - working but x sucks


    SuSE 9.1 x86
    riva TNT 2 64

    well i will start all over again
    im trying to make my nvidia work for my SuSE for about 2 months now =)
    ever sync the new kernel now my x worked but glxgears was been at max 30 fps. soo slow.
    iven when ive goted nv diver it was benn about 125-140 fps
    but probrams like Blender ( a 3d modeler ofr linux ) worked really slow
    hmm quake at 1 fps :
    after instaling nvidia from their site archive diver 5*** worked but kde/x looked mouse had "its tail " only fonts no buttons etc. i will send a screenshot soon .
    but after runing blender it worked super fast
    didnt had q3 then.
    but this was been ever sync old kernel.
    instaling new kernel and nvidia from site archive worked nice whith my x but glxgears had max of 60 fps
    and blender was not that fast
    NOW instaling using new kernel and you gives me that crapy looking x
    but quake runs just fine sound too.

    if time will be on my side i will check other versions of nvidia like 4**** or 6**** of and the newest driver 7**** dont works x crash

    thinx for any replays and sory for my english

  2. #2
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Why don't you just install the nvidia driver via YOU (YaST Online Update)?

    If you go down the list it gives of programs/updates the nvidia driver should be there.

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    8
    i will check that and make a replay soon

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2005
    Posts
    8
    well OK nvidia from "YOU" works just fine
    but its working at 16 bits color after setting 24 bits graphic looks cooler but 2 or 3 times slower any idelas ?

  6. #5
    Just Joined!
    Join Date
    Apr 2005
    Posts
    8
    next problem is sound after running xmms everything freezes but sound keeps on
    after going back to nv driver sound works normal but no glx
    o and quake 3 works just fine ( don't freezes ) at nvidia ...

  7. #6
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Strange, have you tried another player such as zinf?

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  8. #7
    Just Joined!
    Join Date
    Apr 2005
    Posts
    8
    whats what get when installing znif

    /opt/gnome/lib/libgdk-x11-2.0.so.0: undefined symbol: g_unsetenv
    /opt/gnome/lib/libgdk-x11-2.0.so.0: undefined symbol: g_unsetenv
    /opt/gnome/lib/libgdk-x11-2.0.so.0: undefined symbol: g_unsetenv
    /opt/gnome/lib/libgdk-x11-2.0.so.0: undefined symbol: g_unsetenv
    /usr/lib/zinf/plugins/m3u.plf: undefined symbol: _ZN4HttpC1EP9FAContext
    /usr/lib/zinf/plugins/pls.plf: undefined symbol: _ZN4HttpC1EP9FAContext
    No UI plugin in '.:~/.zinf:/usr/lib/zinf' matched 'plugins/musicbrowser.ui' or 'plugins/musicbrowser.ui.ui.'
    Zinf will quit.

    but i thing thats no big deal
    and i will try more on when x crashes or freezes

  9. #8
    Just Joined!
    Join Date
    Apr 2005
    Posts
    8
    hehehe
    now when i want to run zinf it says:

    (<unknown>:8172): Gdk-WARNING **: Attempt to draw a drawable with depth
    24 to a drawable with depth 32

    (<unknown>:8172): Gdk-CRITICAL **: file gdkwindow-x11.c: line 2336 (gdk_
    window_set_back_pixmap): assertion `pixmap == NULL || gdk_drawable_get_d
    epth (window) == gdk_drawable_get_depth (pixmap)' failed
    The program '<unknown>' received an X Window System error.
    This probably reflects a bug in the program.
    The error was 'BadMatch (invalid parameter attributes)'.
    (Details: serial 512 error_code 8 request_code 62 minor_code 0)
    (Note to programmers: normally, X errors are reported asynchronously;
    that is, you will receive the error a while after causing it.
    To debug your program, run it with the --sync command line
    option to change this behavior. You can then get a meaningful
    backtrace from your debugger if you break on the gdk_x_error() function.)

    but i've got a Kaboodle player and runs fine as for now
    yesterday download starcraft demo and runs just fine with oss device

  10. #9
    Just Joined!
    Join Date
    Apr 2005
    Posts
    8
    well im still alive and waiting for more ideas about nvidia
    I've made more tests when x freezes and it don't depends on sound( That much )
    yea when i just startex x and login i start xmms press play and x freezes but music keeps on...
    next I've used runlevel editor to not load alsa at all
    after reboot started game quake played around half hour when I've exited the game x freezz....
    soo I've try to don't use sound and any game , using only internet related programs it keep like this half H.
    but strange thing is that it doesn't x seem to halt internet led was still been flashing disk usage too

    soo now try to write something more OK =)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •