Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
Sorry but since installing SuSE 9.2 personal I've never actually used the Gnome desktop, because I actually prefer KDE...but I just logged out to login to Gnome, and there isn't ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! petergriffin's Avatar
    Join Date
    Nov 2004
    Location
    East Midlands, UK
    Posts
    93

    really dumb question...


    Sorry but since installing SuSE 9.2 personal I've never actually used the Gnome desktop, because I actually prefer KDE...but I just logged out to login to Gnome, and there isn't an option for Gnome! There are several others like 'failsafe', 'admin', 'KDE' and 'default' but how do I login to Gnome?

    I have installed Gnome, as I missed doing so the first time i installed not long ago & so made sure I did choose both KDE & Gnome to be installed this time, and YaST tells me it is def there...

    I probably should have posted this in the newbie section - but I wasn't sure if there would be many SuSE users around to answer this... i am totally baffled by it! BTW during install, I didn't choose KDE as default desktop or anything so I don't know why it didn't give me the option

    Please someone help me with this... Thank you

  2. #2
    Just Joined!
    Join Date
    Nov 2004
    Location
    AU
    Posts
    58
    Copy/Paste this text into an editor (Kate, Kwrite, etc)

    Code:
    [Desktop Entry]
    Encoding=UTF-8
    Name=GNOME
    Comment=This session logs you into GNOME
    Exec=/usr/bin/gnome-session
    Type=Application
    And save it as gnome.desktop to these locations:

    /opt/kde3/share/apps/kdm/sessions/
    /usr/share/xsessions
    /etc/X11/dm/Sessions

  3. #3
    Just Joined! petergriffin's Avatar
    Join Date
    Nov 2004
    Location
    East Midlands, UK
    Posts
    93
    Quote Originally Posted by junme
    Copy/Paste this text into an editor (Kate, Kwrite, etc)

    Code:
    [Desktop Entry]
    Encoding=UTF-8
    Name=GNOME
    Comment=This session logs you into GNOME
    Exec=/usr/bin/gnome-session
    Type=Application
    And save it as gnome.desktop to these locations:

    /opt/kde3/share/apps/kdm/sessions/
    /usr/share/xsessions
    /etc/X11/dm/Sessions
    Thanks - I followed your instructions, but in /opt/kde3/share/apps/kdm/sessions/ there already was a file named gnome.desktop and it asked if I wanted to overwrite it... the other 2 I got as far as /usr/share/ but there was no xsessions and with /etc/X11/ no dm file.

    Am I missing important files then to make Gnome work or something?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    Quote Originally Posted by petergriffin
    Thanks - I followed your instructions, but in /opt/kde3/share/apps/kdm/sessions/ there already was a file named gnome.desktop and it asked if I wanted to overwrite it... the other 2 I got as far as /usr/share/ but there was no xsessions and with /etc/X11/ no dm file.

    Am I missing important files then to make Gnome work or something?
    it might be /etc/X11/xdm
    and i think he means save it as a file called xsessions in the /usr/share folder?
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  6. #5
    Just Joined!
    Join Date
    Nov 2004
    Location
    AU
    Posts
    58
    and i think he means save it as a file called xsessions in the /usr/share folder?
    the gnome.desktop part is right I am presuming, though your using KDM
    for log in

  7. #6
    Just Joined! petergriffin's Avatar
    Join Date
    Nov 2004
    Location
    East Midlands, UK
    Posts
    93
    I am confused here. When you install SuSE you are either given the option of installing just KDE or both kDE & Gnome. Should I see Gnome at the login page? I have all these others like failsafe/admin etc, but if I'm supposed to see Gnome at login as well then I know that something went wrong with my install. I am quite prepared to re-install if it saves all this messing about

  8. #7
    Just Joined! petergriffin's Avatar
    Join Date
    Nov 2004
    Location
    East Midlands, UK
    Posts
    93
    so no one can tell me if gnome appears in their menu/session type on the login page in SuSE?

  9. #8
    Just Joined!
    Join Date
    Feb 2005
    Location
    UK
    Posts
    67
    No it doesn't appear on my install of SuSE 9.2 Pro either and I'm sure I installed it...

  10. #9
    Linux Engineer
    Join Date
    Mar 2005
    Location
    Where my hat is
    Posts
    766
    I believe there's an option that you can select that shows the various managers that you can select on login. Been a while since I've played around with that distro, so I can't remember it right off the top of my head.
    Registered Linux user #384279
    Vector Linux SOHO 7

  11. #10
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    just another thought, it might be worth a look in SuSE Comtrol Centre, or also in the /etc/sysconfig editor in YaST.
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •