Find the answer to your Linux question:
Results 1 to 10 of 10
Suse 9.2 on master drive Winxp on 2nd partition of slave drive 1st partition on slave drive is fat 32 with basically nothing on it. I am wanting to do ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    14

    two drives - suse/winxp


    Suse 9.2 on master drive
    Winxp on 2nd partition of slave drive
    1st partition on slave drive is fat 32 with basically nothing on it.

    I am wanting to do the dual boot thing and trying to do things the hard way without reinstalling linux. I tried using the Bootloader Configuration in YaST but keep getting a Filesystem type unknown error when I try different settings and reboot. Also while there I try a reset to Propose new configuration and for windows it gives hd1,0 (/dev/hdb1). When I run that, I get other errors and have to reboot.

    I found alot of websites with help but they are confusing me since most seems to want me to reinstall linux which is really not an option.

    I am lost, confused and am about ready to say heck with it and leave the side of the computer off so I can switch cables whenever I need winxp. So...any help would be appreciated.

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    try editing the /etc/grub/menu.lst file manually to include:

    Code:
    ###Don't change this comment - YaST2 identifier: Original name: windows###
    title Windows
        root (hd1,0)
        chainloader +1
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    14
    The path is not working. Cannot find a grub folder within /etc/. However I found the file in /boot/grub/ but I am unable to open it. Says that I do not have permission. I do not know enough about linux to open it in terminal.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2005
    Posts
    93
    in terminal type "su", then enter root password - this is super user, use with care
    or, find the file manager - super user mode in the green button, bottom left, this will allow you to navigate as root
    or, switch user to root, using log out => end session=> log in as root.
    Once you can access the grub files, there are many topics already discussing the options that can be used (one of them was mine from 4 months ago when i installed for the 1st time!).

  6. #5
    Just Joined!
    Join Date
    Jan 2005
    Posts
    14
    Unfortunately the suggestion changing the menu.1st did not help. Getting filesystem type unknown error

  7. #6
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    it's menu.lst (not a 1, a lowercase L)
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  8. #7
    Just Joined!
    Join Date
    Jan 2005
    Posts
    14
    yes I mistyped the file extension. But knowing this does not help the problem. I edited the correct file inspite of the wrong path given and it still did not work.

  9. #8
    Just Joined!
    Join Date
    Jan 2005
    Posts
    93
    you need to include the following commands:

    "hide (hd0,3)" where 0,3 should be renamed to your suse partition - this should stop windows seeing suse, use in a pair with...
    "unhide (hd0,0)" dont think really necessary, but 0,0 should be xp partition. Both placed at beginning of windows entry eg
    title windows
    hide
    unhide

    "makeactive" - should be placed after "root", but before "chainloader" to make sure that this root partition is the one used?

    "boot" - placed at end of windows entry- tells grub to actually boot windows!

    keep the rest as it is (including "chainloader")


    good luck!
    p.s. Im in windows at the moment, but i can post my grub setup if this still doesnt work or make sense....

  10. #9
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    Quote Originally Posted by headhunter600
    The path is not working. Cannot find a grub folder within /etc/. However I found the file in /boot/grub/ but I am unable to open it. Says that I do not have permission. I do not know enough about linux to open it in terminal.
    Sorry, my bad, it's /boot/grub/menu.lst
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  11. #10
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Add this to your menu.lst file

    title Windows
    root (hd1,0)
    chainloader +1


    if that doesn't work, add "hdb1" behind (hd1,0)
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •