Find the answer to your Linux question:
Results 1 to 3 of 3
Hello. 1. I have an old PC, 72Mb RAM P133 and have installed SuSE 7.1 recently. The glibc is a 2.2 version and I would like to know how to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2

    Hi. How to upgrade to glibc 3.2.3 from SuSE 7.1


    Hello.

    1. I have an old PC, 72Mb RAM P133 and have installed SuSE 7.1 recently. The glibc is a 2.2 version and I would like to know how to upgrade to 3.2.3. This is because I want to try some other software like Firefox 1.02.

    2. Will the upgrade cause any other program e.g. gcc/g++, samba, etc. not working at all?

    Thanks in advance.

    ps: I am a complete newb at this. I have to download this from ftp://ftp.gnu.org/pub/gnu/gcc/gcc-3.2.3.tar.gz, am I right not? After doing so, what do I need to do? Many thanks again.

  2. #2
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    Well, the first question is whether you need SuSE 7.1 or not. The current version is 9.2, and installing that would make RPMs easier to use.

    That said, if for some reaosn you need 7.1, YaST will automatically detect dependencies and junk. I did an RPMFind search for you, the results for glibc are at:

    http://speakeasy.rpmfind.net/linux/r...suse+7.1&arch=

    Try some of those RPMs. Are you using KDE? If so, just download the file, open konqueror, and go to it. Click on it and select "Install with YaST". It will tell you if your dependencies are all farked up. If they are, don't install.


    Actually, before doing all that, you might want to do a YaST search for glibc, and see if this version is already there...

    But your best bet is probably to update to SuSE 9.2.

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2
    Thanks for the reply. I will try it now.

    1. Yes I do need SuSE 7.1 coz it is the orignal discs that I have can be seen by my laptop's old 4x cdrom drive. It can not see the cdr media these days so I can not use the latest SuSE.

    2. BTW, can you please teach me how to search for this RPM dependencies?

    3. Also, how do I do a Yast search?

    4. It says,

    Unsatisfied dependencis: filesystem.

    Does it mean safe to install?

    5. There is a check box for Test (do not install). So if I decide to check it and install and if it does not work, there will be no harm to my computer right? Also, if the test is failed, will it automatically clean the failed installation?

    6. If I update glibc, do I have to update libc as well?

    Thanks again.

    ps: Sorry if my questions are a little too trivial.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •