Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13
Originally Posted by fofeppe ...i mounted 2partitions in /windows/C (vfat) and /data1 (reiserfs)... but as normal user i can't write, but only read those partitions... only as root i can ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Engineer
    Join Date
    Mar 2005
    Location
    Where my hat is
    Posts
    766

    Quote Originally Posted by fofeppe
    ...i mounted 2partitions in /windows/C (vfat) and /data1 (reiserfs)...
    but as normal user i can't write, but only read those partitions...
    only as root i can write
    Then you have a permissions issue. Post the contents of /etc/fstab and we'll get you straightened out.
    Registered Linux user #384279
    Vector Linux SOHO 7

  2. #12
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    Quote Originally Posted by fofeppe
    ...i mounted 2partitions in /windows/C (vfat) and /data1 (reiserfs)...
    but as normal user i can't write, but only read those partitions...
    only as root i can write
    you need to change the options in the fstab try this:

    Code:
    /dev/hda1   /media/win/c vfat users,umask=0002,gid=users 0 0
    the umask, dmask and gid set the permissions of files, folders and the group owner, allowing your normal user write permissions to the mounted drives. also, the users at the start means that your normal user can mount/umount the drive
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  3. #13
    Just Joined!
    Join Date
    Mar 2010
    Posts
    1

    Solution:

    SOLUTION:

    add this line:
    su - -c "/bin/bash startx" root

    to /etc/rc.d/after.local

    Then change your default run level to 3 in /etc/inittab

    done.

  4. $spacer_open
    $spacer_close
Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •