Find the answer to your Linux question:
Results 1 to 7 of 7
I am trying to install my Plantronics Audio 50 USB Headset (Has a USB DSPv2 Dongle). It is detected in the list of usb devices. but not in the list ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    8

    Plantronics Audio 50 USB Headset


    I am trying to install my Plantronics Audio 50 USB Headset (Has a USB DSPv2 Dongle).
    It is detected in the list of usb devices. but not in the list of sound cards. When i go to add a sound card, I can get the usb headset playback (havent tried record) to work by adding it using USB Generic driver set. But when I do that my primary sound card "AC97" stops working. and the "test" button on both sound card profiles plays sound from my usb headset speakers. Is there a way to fix this that anyone knows of? I want to get my headset working inside Teamspeak for Linux. But this is throwing me for a loop!

    (Note: I am using SuSE 9.3 Professional)

  2. #2
    Just Joined!
    Join Date
    May 2005
    Posts
    8

    * BUMP *

    *BUMP*

    Does anyone have any suggestions on my problem?? If i need to provide more information I would be glad to.

  3. #3
    Linux User eugrus's Avatar
    Join Date
    Dec 2004
    Location
    Russia
    Posts
    391
    Are you using Alsa or OSS?

  4. #4
    Just Joined!
    Join Date
    May 2005
    Posts
    8
    Quote Originally Posted by eugrus
    Are you using Alsa or OSS?
    Do you mean for the USB Sound card?????

    I do not know how to install it, So I do not know where to put settings like that. Like i said when I do install it as a generic USB sound card it disables my onboard AC97 sound for some reason.

  5. #5
    Just Joined!
    Join Date
    May 2005
    Posts
    8

    *BUMB*

    *BUMB*

  6. #6
    Just Joined!
    Join Date
    Jan 2007
    Posts
    2
    Quote Originally Posted by eugrus
    Are you using Alsa or OSS?

    That's a good question in that I think it will make USB Plantronics headsets work in Linux. I've read around and found out that when installing 'Skype', it will give you the option to choose various sound devices such as Alsa on /dev/dsp or OSS /dev/dsp1. The one on /dev/dsp1 is what I needed to select to play audio through the Plantronics headset.

    Unfortunately, when I uninstalled 'Skype', the audio would revert back to my notebooks speakers.

    So my questions is, How do I tell the OS to play my audio through OSS /dev/dsp1 instead of Alsa?

    Thanks for your help.

    btw.
    running
    Dell Notebook
    Inspiron e1405
    openSUSE 10.2

  7. #7
    Just Joined!
    Join Date
    Jan 2007
    Posts
    2
    Ok, I'm getting closer to solving this.

    I went to 'Configure Desktop (Personal Settings)'.
    'Sound & Multimedia'
    'Sound System'

    Under the 'Hardware' tab, I have the option to choose an audio device. It's currently set to 'Auto Detect'. I've tried changing to 'ALSA' and then to 'OSS' but when I play audio, it still seems to play through my notebook speakers.

    I then noticed a checkbox called 'Override device location', I did a 'help' on it and received this message.

    ""Normally, the sound server defaults to using the device called /dev/dsp for sound output.That should work in most cases. On some systems where devfs is used, however, you may need to use /dev/sound/dsp instead. Other alternatives are things like /dev/dsp0 and /dev/dsp1, if you have a soundcard that supports mulitple outputs, or you have multiple soundcards.""

    I checked that box and under that field, I typed /dev/dsp1. Restarted and no avail

    I've tried that same setting with the audio device of 'ALSA' 'OSS' and 'Auto Detect'.

    If I open up Skype and go to 'Tools' 'Options' 'Sound Devices', under 'Audio System to use:' I have 2 options

    OSS - 2 device(s) found
    ALSA - 2 device(s) found

    If I select 'ALSA' with 'HDA Intel', the audio will be played through the notebooks speakers.
    If I select 'ALSA' with 'Plantronics Headset' the audio will go through USB Plantronics Headset

    If I select 'OSS' with '/dev/dsp', the audio will be played through the notebooks speakers.
    If I select 'OSS' with '/dev/dsp1', the audio will go through USB Plantronics Headset

    I think I'm very close to figuring this out. If anybody can help me out, I would greatly appreciate it.

    Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •