Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
I recently purchased a HP a1130n which came with XP media edition on it. First boot, i reformatted the sucker as a dual boot with XP pro and Suse 9.3 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jan 2005
    Location
    Pennsylvania
    Posts
    116

    Video Card and System Clock


    I recently purchased a HP a1130n which came with XP media edition on it. First boot, i reformatted the sucker as a dual boot with XP pro and Suse 9.3 64 bit.

    The machine specs are here: HP a1130n

    My problems with this are:
    1. The system clock on the desktop is running exactly 2 times faster than normal. 1 sec. = 2 sec. I've set the clock to update from a url within YAST instead of local, but that doesn't fix it.

    2. The pc has the ATI Radeon Xpress 200 on-board video, which Suse doesn't support. I went to ATI's site and downloaded the new driver for it, but cannot get it to work to save my life.

    If anyone has any tips, i'd greatly appreciate it... And owe you a BEER!

    Cheers,

    Carbon8
    Register Linux User #388393
    _________________________________________

  2. #2
    Linux Newbie ihayhurst's Avatar
    Join Date
    Jun 2005
    Location
    UK
    Posts
    138
    This piqued my curiosity, so I did a bit of googling... and wouldn't you know I came across some one with your problem , and with the same card !
    https://bugzilla.redhat.com/bugzilla...buglist=152630

    hope it helps with your problem,

    Cheers Ian
    Registerd Linux user #119296

  3. #3
    Linux Newbie
    Join Date
    Jan 2005
    Location
    Pennsylvania
    Posts
    116
    Ok. Thanks!
    That fix looks like it's for kernel 2.4.x
    I'm using 2.6.11 i believe. I followed a link over to another bug listing where the guy said that patch has been made in 2.6.x, but didn't fix the problem. He's got a fix listed to patch timer.c, but i cant find that file on my box anywhere.
    Register Linux User #388393
    _________________________________________

  4. #4
    Linux Newbie
    Join Date
    Jan 2005
    Location
    Pennsylvania
    Posts
    116
    Well, i managed to fix the clock by going back to Suse 9.3 32 bit. It seems to be a common problem with 64 bit systems. I guess 64 just isn't quite here yet. Not to mention the programs not available yet under 64.

    Ordered a new video card so that will take care of that issue.

    Thanks for the help!
    Register Linux User #388393
    _________________________________________

  5. #5
    Linux Newbie
    Join Date
    Jan 2005
    Location
    Pennsylvania
    Posts
    116
    I got the video issue fixed by purchasing a X300 xpress pci card. Now that's off my list.

    I tried to add noapci to the boot/grub/menu.lst and now i cannot boot the system. Grub comes up, i choose suse and it goes to a black screen. I tried adding a boot parameter at the grub screen (apci=on) and that made no difference. I tried the failsafe mode, and that made no difference.

    How do i go about getting back into my menu.lst and removing that param without booting??
    Register Linux User #388393
    _________________________________________

  6. #6
    Linux Newbie ihayhurst's Avatar
    Join Date
    Jun 2005
    Location
    UK
    Posts
    138
    boot from a floppy or rescue distro (makesure that it supports your filesystem... I use reiser so my old standby of tomsrootboot needs updating)
    mount the filesystem with your boot folder in (sometimes boot is a different partition), edit the grub.conf or menu.lst (using the full path ... ie include the mount point)
    eg , to fix my gentoo build I boot from the gentoo cd,
    mount -t reiserfs /dev/hda1 /mnt/gentoo

    /dev/hda1 is my root and has a boot folder on it so I edit
    /mnt/gentoo/boot/grub/grub.conf (normally it's /boot/grub/grub.conf)

    Hope that helps
    Cheers
    Ian
    Registerd Linux user #119296

  7. #7
    Linux Newbie ihayhurst's Avatar
    Join Date
    Jun 2005
    Location
    UK
    Posts
    138
    ok SuSe I forgot, same applies, though you can boot from the install disks,
    don't install but you should get the option to boot a rescue system

    then proceed as per my last post
    Registerd Linux user #119296

  8. #8
    Linux Newbie
    Join Date
    Jan 2005
    Location
    Pennsylvania
    Posts
    116
    Excellent. Thanks Ian.
    I'll be back shortly with a progress report.
    Register Linux User #388393
    _________________________________________

  9. #9
    Linux Newbie
    Join Date
    Jan 2005
    Location
    Pennsylvania
    Posts
    116
    I'm back up and running. Thanks for your help Ian!!

    Has anyone else had problems with the system clock on 64 bit OS's? I cannot seem to find a suitable fix for this. I'm a little worried about trying the bug fix that was posted here from bugzilla since it's on the redhat list. I was told that booting with the noacpi option would solve it but it only brought my system down. I surely don't want to run in 32 bit mode if i don't have to.
    Register Linux User #388393
    _________________________________________

  10. #10
    Linux Newbie ihayhurst's Avatar
    Join Date
    Jun 2005
    Location
    UK
    Posts
    138
    Great stuff !

    Beware of confusing acpi and apic
    I think (though not 100%) that acpi is set with apci=on and acpi=off
    (that's powersaving Advanced Configuration and Power Interface)

    apic is Advanced Programable Interupt Controller
    and is done with noapic

    I cant tell from your post which you were doing as you mentioned acpi=on and noacpi (rather than noapic)...

    Cheers Ian
    Registerd Linux user #119296

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •