Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
When suse 9.3 is booting i get the DMA off could slow down fsck etc.. In a root shell i turned it on using hdparm, when i rebooted tho it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! dave`2005's Avatar
    Join Date
    Aug 2005
    Posts
    45

    Turned DMA on but its still off.


    When suse 9.3 is booting i get the DMA off could slow down fsck etc.. In a root shell i turned it on using hdparm, when i rebooted tho it still told me it was off I know i havent given any details but im not sure how to get them Sorry. Maybe someone can let me know what command to use to get relivant details. Im completely new to linux (i think u knew that already) any help at all would be appreciated.

    Dave

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Here's a HowTo that might provide some clues:

    http://www.faqs.org/docs/Linux-mini/Ultra-DMA.html

    Post back if it doesn't help.

  3. #3
    Just Joined! dave`2005's Avatar
    Join Date
    Aug 2005
    Posts
    45
    I read that, i cant see a part about if youve enabled dma but its still not working

    i used the hdparm -i /dev/hda and it gave me this:

    /dev/hda:

    Model=ST320413A, FwRev=3.54, SerialNo=7ED1BS1S
    Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs RotSpdTol>.5% }
    RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=0
    BuffType=unknown, BuffSize=512kB, MaxMultSect=16, MultSect=16
    CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=39102336
    IORDY=on/off, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
    PIO modes: pio0 pio1 pio2 pio3 pio4
    DMA modes: mdma0 mdma1 *mdma2
    UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5
    AdvancedPM=no WriteCache=enabled
    Drive conforms to: device does not report version: 1 2 3 4

    Anything in there that means anything to the more competant suse user?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer LondoJowo's Avatar
    Join Date
    May 2005
    Location
    Richmond, TX
    Posts
    804
    Open YaST, Hardware, and IDE DMA Mode, what does it show?

    Highlight the drive if there are more than one, click on the selection at the bottom that more than likely says "no change", select the DMA mode that matches the drive (ie UDMA100), and click finish.

  6. #5
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429
    The *mdma2 means that is the enabled mode. Strange, never seen 'mdma' though... But in YaST, you can set DMA graphically. And it will stay activated, also if you reboot.
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

  7. #6
    Linux Engineer LondoJowo's Avatar
    Join Date
    May 2005
    Location
    Richmond, TX
    Posts
    804
    I think the problem is that it's DMA and not UDMA. Unless this is some ancient DMA16 drive, it should be UDMA 66 or above. My DVD writers are automatically configure UDMA33 by SuSE during the install.

    I've also found out it better to configure things in YaST rather than editing configuration files as SuSE loves to rewrite them and you've lost your edits.

  8. #7
    Just Joined! dave`2005's Avatar
    Join Date
    Aug 2005
    Posts
    45
    In yast i set the dma mode to UDMA100 and rebooted, it said that dma was turned off when booting up, yast said the same thing, its off, but under required mode it said UDMA100. Then in yast i chose the on(default) option and rebooted, it still says off, this time under required mode it said on(default). Any more ideas?

    Just wanted to add i've tried all UDMA modes now, all get the same thing.

  9. #8
    Just Joined! dave`2005's Avatar
    Join Date
    Aug 2005
    Posts
    45
    not too sure whats happened now, in the bios i disabled LBA on the hdd, then got the same thing, i then tried dma16 as i saw it working for the cdrom drive, now when its booting up it says:

    setting dma mode to 1 (on)
    setting xfermode to 34 (multiword DMA mode2)
    hda: dma_timer_expiry: dma status ==0x21
    hda: DMA timeout error

    Then it stays there. Someone please help

  10. #9
    Linux Engineer LondoJowo's Avatar
    Join Date
    May 2005
    Location
    Richmond, TX
    Posts
    804
    Is your harddrive and CD drive on the same cable by chance? Or have you recently changed the drive cable?

  11. #10
    Just Joined! dave`2005's Avatar
    Join Date
    Aug 2005
    Posts
    45
    in the bios the hdd is the primary master, and the cdrom drive is the secondary slave. havent changed anything.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •