Find the answer to your Linux question:
Results 1 to 6 of 6
Hallo an alle, seit meinem Kernel-Umstieg von Suse 9.2-Kernel 2.6.8 auf Vanilla-Kernel Version 2.6.12.5 braucht udev beim Start ca 3 Minuten ehe es weitergeht. Meldung: starting udev creating devices (ca. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    5

    Kernel-Version 2.6.12.5 + udev-Version?


    Hallo an alle,

    seit meinem Kernel-Umstieg von Suse 9.2-Kernel 2.6.8 auf Vanilla-Kernel Version 2.6.12.5 braucht udev beim Start ca 3 Minuten ehe es weitergeht.
    Meldung:
    starting udev
    creating devices
    (ca. 3 Minuten geht nichts mehr)
    (Mit dem Original-Suse-Kernel geht der Boot-Vorgang wie gewohnt schnell über die Bühne.)

    Danach bootet Linux ganz normal weiter. Ist es richtig, daß für eine bestimmte Kernel-Version eine bestimmte udev-Version installiert sein sollte? Wenn ja welche udev-Version brauche ich für Kernel 2.6.12.5? Und gibt es Probleme wegen des Vanilla-Kernels? Kann ich udev einfach drüber installieren oder muß ich davon ausgehen damit mein ganzes Linux lahmzulegen?

    Grüße,
    Tom

  2. #2
    Linux Engineer d38dm8nw81k1ng's Avatar
    Join Date
    Mar 2005
    Location
    Newcastle
    Posts
    793
    this is an english forum, so translate your message please.
    Here's why Linux is easier than Windows:
    Package Managers! Apt-Get and Portage (among others) allow users to install programs MUCH easier than Windows can.
    Hardware Drivers. In SuSE, ALL the hardware is detected and installed automatically! How is this harder than Windows' constant disc changing and rebooting?

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Posts
    5

    english translation

    I'm sorry, that's the reason I'm posting here

    Here is the translation of my question:
    Since my upgrade from Kernel 2.6.8 (Suse 9.2-Kernel) to Vanilla-Kernel 2.6.12.5 needs my Linux to boot several minutes. It seems to stop when trying to start udev. The messages are as following:

    creating udev
    creating devices
    (with originial Suse-Kernel 2.6.8 ist works much faster)

    After that Linux continues booting normally. Is it right that I need a specific udev-version for this specific Kernel-version? Or is it possible to just install a newer version of udev when I have installed an older one, perhaps a specific Suse-one (Suse 9.2 is using udev 0.5x)?

    Thank you. Regards,
    Tom

  4. #4
    Just Joined!
    Join Date
    Oct 2005
    Posts
    2
    Hi Tom,
    have you been able to resolve your problem? I have the same troubling me, and I have not been able to find a solution so far (actually, I seem to make it only worse.. )
    Concerning the udev version needed by the kernel: You can find this information under ./Documentation/Changes in the source-tree.

    I've updated to kernel 2.6.13 (kotd xx.09.2005) in an attempt to resolve some usb problems. I installed udev 070 (current version), but afterwards I had to wait for several minutes for udev everytime I rebooted (same thing you have described).

    Switching to 053 from ftp://ftp.suse.com/pub/people/agruen/ didn't help me either.

    The message you've quoted is displayed while running through initrd - I suppose that there are some changes needed in the mkinitrd config but I have not gotten beyond upgrading mkinitrd to version 1.2-28 (supplied by suse - see link above).

    If you or anybody else has some insight into this issue, I'd be thankful if you could post some clues!

    Thank you!

  5. #5
    Just Joined!
    Join Date
    Oct 2005
    Posts
    2

    Problem solved

    Just for the record: Updating mkinitrd from the above mentioned link solved the problem for me after all!

  6. #6
    Just Joined!
    Join Date
    Apr 2006
    Posts
    2
    I came across this problem today. I had been using an NVidia video card that went bad.
    When I tried to use the onboard video card, I started having this problem. Redisabling the onboard video and installing a new AGP video card "fixed" it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •