Find the answer to your Linux question:
Results 1 to 5 of 5
Yes, I am a newbie, but I learn quick and I thought this topic was a little beyond the newbie forum. I have two BenQ-FP737s LCD monitors hooked up to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Posts
    3

    Need help configuring dual monitors


    Yes, I am a newbie, but I learn quick and I thought this topic was a little beyond the newbie forum.

    I have two BenQ-FP737s LCD monitors hooked up to a nVidia GeForce 5900XT (1-DVI, 1-VGA). At one point, I had SuSE 9.2 installed and the card/monitors configured to properly use both monitors for my desk space. Recently, I've deleted the SuSE 9.2 partition, formatted it, and installed SuSE 9.3. I would now like to configure 9.3 to extend my desktop across both monitors. Unfortunately, it has been a while since I configured these devices in 9.2, and, in the mean time, I haven't had much opportunity to tinker with or learn much about Linux -- so I have no idea what I did.

    One new thing to throw in the mixture: last time (SuSE 9.2), before I started configuring my dual monitors, the display was cloned - the same picture was on each monitor. This time, my secondary monitor (connected to the VGA-out) has a terribly corrupted-looking display. Picture this: take the top-left quadrant of my main screen (DVI-out), overlay the top-right of my main screen, give it tie-dyed colors and Matrix-esque monitor interference, and that is what you see on my secondary monitor. Assuming that it was a fluke, and that properly configuring X to utilize the secondary monitor would fix the situation, I ignored it and attempted to figure out how to configure dual monitors.

    The Googling that I've done:
    >>dual monitors linux
    >>linux twinview
    >>linux twinview how-to

    That last Google search produced this page: http://gentoo-wiki.com/HOWTO_Dual_Monitors#TwinView -- which I know I used last time to configure my dual monitors properly. [I know, I'm not using Gentoo, but it worked last time.] This time, however, it didn't work so well...or at all for that matter. I still get the same corrupted display on my secondary monitor.

    I'm now wondering if the corrupted display is the result of a problem I didn't have before. I know it's not hardware, both displays work fine in WinXP.

    Things I've considered:
    >>Do I have corrupted drivers for my graphics card or my monitor? (I've tried updating/reinstalling the drivers for both.)
    >>Do I need to enable VGA-out on my graphics card?
    >>Do I need to add a 2nd monitor in YaST2 (or in xorg.conf)?
    >>Is TwinView really the best way to extend my desktop or is there a better, more up-to-date method?
    >>I would think there would be a easier way to set this up (thru YaST2 or SaX2), but when I try and set up multihead, it tells me is that my system doesn't provide more than one graphics mode.

    Can somebody point me in the right direction?

  2. #2
    Just Joined!
    Join Date
    Sep 2005
    Posts
    3
    No ideas?

  3. #3
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Have you looked at this link? That is actually written for Xfree86-4 but may still be helpful with your xorg.
    /IMHO
    //got nothin'
    ///this use to look better

  4. #4
    Linux User cayalee's Avatar
    Join Date
    Sep 2004
    Location
    england
    Posts
    389
    have you got the official nvidia drivers installed? or are you running on the suse default drivers?
    You know, aliens are going to come to earth in 50 years and kill the hell out of us for DDoSing their networks with this SETI crap
    registered linux user #388463

  5. #5
    Just Joined!
    Join Date
    Oct 2007
    Location
    Lebanon Missouri
    Posts
    48
    Try adding or modifying these lines in you xorg.conf file.

    Option "TwinView" "true"
    Option "TwinViewOrientation" "RightOf" # "LeftOf" "Above" "Below" "Clone"
    Option "UseEdidFreqs" "True"
    Option "MetaModes" "1280x1024,1280x1024"

    That should do it for you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •