Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
hey everyone, I have KDE, eveytime i turn on my laptop and try to connect with my wireless, it doesn't work. the only way it'll work is if I go ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2005
    Location
    Chicago
    Posts
    74

    weird way of starting wireless on my SuSE 10


    hey everyone, I have KDE,

    eveytime i turn on my laptop and try to connect with my wireless, it doesn't work. the only way it'll work is if I go to

    YaST Control Center --> Network devices --> Network card

    Then, I click on the name of my wireless card --> edit --> next --> next --> next.

    By doing that, at the end it saves the network configuration and does a bunch of stuff including 'activating network services'. Then i can finally connect to the internet. Under the wireless card, it does already say 'start automatically at boot' so i don't know why i have to go through those steps all the time, is there any way that i can avoid this and have it activate my network services automatically as soon as i logon? Thanks.

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Since you are using SUSE, I assume KInternet is setup to manage your internet connections? Look for something which looks like 2 wires connecting to each other in the taskbar.

    Now right click on this icon, under Settings -> various settings, tell it to start up with the interface wlan0 or whatever your wireless card is called. And tell it to start on KDE login.
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Just Joined!
    Join Date
    Oct 2005
    Location
    Chicago
    Posts
    74
    thanks for your reply, but when i went to check the options, the box was already checked for starting on KDE login and it was already set to eth1 which is what my wireless card is. is there any other way for 'activating the network services'? thanks again.

  4. #4
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    have you configured your wired card? If so tell the system to bring it (the wired card) manually or on cable connection. Now when you start SUSE, without going into yast and resetting up the card, can you paste the outputs from the following commands:
    Code:
    ping -c 4 www.google.com
    route
    Life is complex, it has a real part and an imaginary part.

  5. #5
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    When you're using Kinternet you can manage the connection and bring it up and down by clicking on the tray icon. If your wireless access point is not available every time you boot I recommend setting it to manual and then bringing it up using Kinternet. This should speed booting slightly for you. Does managing it with Kinternet work for you?

  6. #6
    Just Joined!
    Join Date
    Oct 2005
    Location
    Chicago
    Posts
    74
    Quote Originally Posted by AlexK
    have you configured your wired card? If so tell the system to bring it (the wired card) manually or on cable connection. Now when you start SUSE, without going into yast and resetting up the card, can you paste the outputs from the following commands:
    Code:
    ping -c 4 www.google.com
    route
    Below are the commands that i ran:

    Code:
    linux:~ # ping -c 4 www.google.com
    ping: unknown host www.google.com
    
    linux:~ # route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    loopback        *               255.0.0.0       U     0      0        0 lo

  7. #7
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    If so tell the system to bring it (the wired card) manually or on cable connection.
    This suggestion should work.

    Quick explanation: Under SuSE, when you have both an ethernet card and a wireless card set up the default way, you know someone's nameservers will always get clobbered.

    So let's say the wireless card comes up first. It puts its nameservers in /etc/resolv.conf. No problem... until the ethernet card comes up - then it dumps its own nameservers in /etc/resolv.conf, thereby clobbering what was there. Then you may have no name resolution for your wireless card, so you can't cruise the web.

    The way you're doing this in YaST is effectively bringing down and back up the wireless card, which of course clobbers /etc/resolv.conf yet again with the nameservers the wireless connection relys on. So changing the ethernet card to activate when a cable is plugged in should be a good workaround for you.

  8. #8
    Just Joined!
    Join Date
    Oct 2005
    Location
    Chicago
    Posts
    74
    oops, i forgot to set the wired card for manual or on connection, let me do that and i'll get back here for a reply

  9. #9
    Just Joined!
    Join Date
    Oct 2005
    Location
    Chicago
    Posts
    74
    i set the wired card to start 'manually' and then restarted my laptop, and then logged on and still had to go through that stupid process of getting my wireless to work...then i tried setting the wired card to start 'on connection' and then restarted my laptop again, and then logged on and still had to go through that process to get my wireless working...the only difference is that when it's on 'on connection' it makes a beep when the saving configuration runs through the 'activating network services',

    Code:
    linux:~ # ping -c 4 www.google.com
    ping: unknown host www.google.com
    linux:~ # route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    loopback        *               255.0.0.0       U     0      0        0 lo
    linux:~ #

  10. #10
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    Ethernet card should be: When hotplugged (or whatever the option reads exactly).

    Wireless card should be: At boot time.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •