Find the answer to your Linux question:
Results 1 to 6 of 6
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Name resolution under 10.0 doesn't work!!

    Hi, all! Trying to get name resolution to work under 10.0 on three (3) different manufacturer's machines with three different network adapters, and I just can't get it to work. The EXACT same symptoms are on all three machines with new 10.0 installed; one box dual-boots XP/Pro. Windows boxes on the same network behind the same router work perfectly. I'm using YaST to config network adapter options; two network adapters are wired and one is wireless.

    1. IP addressing works perfectly fine; I can load web pages by IP address both internally and externally, and can access external network services via IP just fine.
    2. Problem occurs regardless of firewall being on or off
    3. Problem occurs regardless of port 53 being specifically opened on firewall (when firewall is on).
    4. Problem occurs regardless of whether DNS server is installed or not.
    5. Problem occurs regardless of whether I use DHCP or hard-wire the IP settings
    6. Router has had port 53 opened specifcally for the machine being worked on; no effect (no needed for Windows functionality, so I'm assuming it isn't necessary for Suse functionality, but what the heck).
    7. nslookup attempts all fail, with a response of "No answer."

    /etc/resolv.conf is good; contains three "nameserver" entries, each one pointing to a live, valid DNS server on the 'net (Windows boxes use these same DNS servers, supplied via DHCP). Added "nameresorder dns files nis" (can't remember last param, so I may have types it incorrectly in this post), no effect.

    I'm out of things to check!! Help!!

  2. #2

    DNS Problems

    What router are you using.

  3. #3
    Shaun, thanks for replying. My router is a LinkSys BEFW11S4, firmware version 1.50.14. Just as a note, Windows boxes on the same subnet can resolve names fine using the same DNS servers.

    Also, my original note of using "nameresorder" parameter in /etc/resolv.conf was a typo: the line in my resolv.conf file is "hostresorder dns files nis" and not "nameresorder ...". Sorry for any confusion.

    Still trying to find the problem. Anyone know if this is a known problem with the 10.0 release?


  4. $spacer_open
  5. #4
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    hmm, only two suggestions I can think of:
    1. In yast, under the hostnames and nameserver settings, did you tell it to update dns servers via dhcp?

    2. The other suggestion is to tell the SUSE boxes that your router/gateway is actually a nameserver (that was the way I got the wireless to work on my box).
    Life is complex, it has a real part and an imaginary part.

  6. #5
    Alex, thanks for responding!

    Not using DHCP right now; just have everything hard-coded.

    Also, thanks for the tip with the wireless! I'm trying to get it running correctly on one of these three boxes, anyway!


  7. #6

    Found a resolution (odd, but it works)

    OK, found a solution to the problem. Dunno why it has to work this way, but whatever works...

    With DNS installed and running (firewall is irrelevent, ports open on router is irrelevent), set my /etc/resolv.conf to this:

    nameserver <---- NEW LINE
    nameserver <first DNS IP addy>
    nameserver <second DNS IP addy>
    nameserver <third DNS IP addy> <---- Yes, I know it can only use 3!
    hostresorder files dns nis
    search <first DNS IP> <second DNS IP> <third IP addy>

    It seems the first line, setting loopback as a nameserver, in conjunction with a running DNS Server locally fixed the problem. I find it odd that I have to run DNS server and add this entry in my resolv.conf file to be able to do simple name resolution; anyone have any ideas why this is? I am NOT using DHCP on the box in question (although will be shortly).


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts