Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16
Well, I can't. I get this: alsamixer: function snd_mixer_load failed: Invalid argument...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Feb 2006
    Posts
    10

    Well, I can't. I get this:
    alsamixer: function snd_mixer_load failed: Invalid argument

  2. #12
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    At this point I've run out of ideas, but hang in there. I'm sure someone else will pick up with some other things you can try.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  3. #13
    Linux User oosterhouse's Avatar
    Join Date
    Jan 2006
    Location
    Grand Rapids, MI
    Posts
    318
    Did you try "amixer set 95 Master unmute" and "amixer set PCM 95 unmute" as root? Might work, not sure.

  4. #14
    Just Joined!
    Join Date
    Feb 2006
    Posts
    10
    Quote Originally Posted by techieMoe
    At this point I've run out of ideas, but hang in there. I'm sure someone else will pick up with some other things you can try.
    Sure thing. Thanks anyway.

  5. #15
    Linux Engineer oldcpu's Avatar
    Join Date
    Aug 2005
    Location
    Europe
    Posts
    1,142

    some ideas

    Quote Originally Posted by Johannes
    I have installed SuSE 10, and I can't seem to make my sound card work. This is a laptop, so I can't buy a new soud card.
    No solution, but some ideas.

    Did you try:
    a. going into your laptop BIOS and ensuring sound is ENABLED,
    b. type "su" and then go into /etc/modprobe.d and rename every file that has the ascii character sequence "sound" in the file name. I say rename so you can restore the file.
    c. then go to YAST > HARDWARE > SOUND and try to configure any sound card that it may identify. Move slider bars far to the right, and try the test sound function.

    If you get that far, please post, and we can walk you through some other things that need to be done.

    If that fails, maybe try to download the Realtek driver. I saw the following on the web, I don't know if it is the most current, nor if it will work, but its worth checking out:
    http://www.driverskit.com/freedownlo...nux/15316.html

    Good luck

  6. #16
    Just Joined!
    Join Date
    Apr 2006
    Posts
    1
    I have Suse 10 on a desktop system with an ATI RS482M4-ILD motherboard, which has the same Realtek ALC880 sound chipset, and I had the same problem with sound not playing. I got it working after downloading and installing the drivers from Realtek's website. Can't say for sure that that's the step that made it work, as tried quite a few, but I think it is.

    Download from here

    The included installed directions and scripts are mostly good. I safely ignored step 2 because sound support is on by default. Step 4 asks you to edit modules.conf, which SUSE doesn't have. I ended up inserting the following lines into /etc/modprobe.d/sound:

    alias char-major-116 snd
    options snd major=116 cards_limit=1
    alias snd-card-0 snd-hda-intel
    options snd-hda-intel index=0 id="HDA"
    alias char-major-14 soundcore
    alias sound-slot-0 snd-card-0
    alias sound-service-0-0 snd-mixer-oss
    alias sound-service-0-1 snd-seq-oss
    alias sound-service-0-3 snd-pcm-oss
    alias sound-service-0-8 snd-seq-oss
    alias sound-service-0-12 snd-pcm-oss
    Anyway, good luck.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •